[FIX]CalculateBlockSideMargins computes wrong margin in overconstrained case

RESOLVED DUPLICATE of bug 364079

Status

()

RESOLVED DUPLICATE of bug 364079
12 years ago
12 years ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

Trunk
mozilla1.9alpha1
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

12 years ago
The problem is that we set the right or left margin to auto, but don't adjust the availMarginSpace to include the margin we just forgot.  For LTR stuff this doesn't matter much (we just get an incorrect right margin), but for RTL we get an incorrect left margin and hence position the block in the wrong place; the testcase shows this.
(Assignee)

Comment 3

12 years ago
Ah, crap.  I had this all typed up before he filed, but didn't manage to commit the form then.

*** This bug has been marked as a duplicate of 364079 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.