Closed Bug 364420 Opened 13 years ago Closed 13 years ago

Monthly layout: Left-align events on monthly calendar

Categories

(Calendar :: Printing, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: CarlPonder, Assigned: martinschroeder)

Details

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061116 Fedora/1.5.0.8-2_EL4 (CK-IBM) (CK-IBM) Firefox/1.5.0.8
Build Identifier: SunBird 0.3

I print the "calendarPrint.html" file using the "opera" browser, so I can get a full month grid on tabloid paper. It's a bit odd that the events are horizontally centered; it would look better if they are all left-aligned.

Reproducible: Always
Summary: Left-align events on monthly calendar → Monthly layout: Left-align events on monthly calendar
Attached patch Patch v1 (obsolete) — Splinter Review
The event time and description in the "Monthly Grid" should appear left aligned.

Is a second review needed for this small fix?
Assignee: nobody → mschroeder
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #252363 - Flags: first-review?(lilmatt)
OS: Linux → All
Hardware: PC → All
Version: unspecified → Trunk
Comment on attachment 252363 [details] [diff] [review]
Patch v1

>Index: calMonthGridPrinter.js
>===================================================================
>             } catch(ex) {}
> 
>             var style = 'font-size: 11px; background-color: ' + calColor + ';';
>             style += ' color: ' + getContrastingTextColor(calColor);
>             if (catColor) {
>                 style += ' border: solid ' + catColor + ' 2px;';
>             }
>             var item = <tr>
>-                           <td valign='top' align='center' style={style}>{time} {item.title}</td>
>+                           <td valign='top' align='left' style={style}>{time} {item.title}</td>
>                        </tr>;
>             innerTable.appendChild(item);
>         }

I'd rather move more formatting into CSS if possible.
Remove the align='center' and try adding 'text-align=left;' to style above.

Does this produce the same result?
Attached patch Patch v2Splinter Review
Moved alignment to var style as suggested. This produced the same result.
Attachment #252363 - Attachment is obsolete: true
Attachment #252449 - Flags: first-review?(lilmatt)
Attachment #252363 - Flags: first-review?(lilmatt)
Comment on attachment 252449 [details] [diff] [review]
Patch v2

Nice. r=lilmatt
Attachment #252449 - Flags: first-review?(lilmatt) → first-review+
Attachment #252449 - Flags: second-review?(mvl)
We all like screenshots... (hint, hint)
Comment on attachment 252449 [details] [diff] [review]
Patch v2

r2=mvl
Attachment #252449 - Flags: second-review?(mvl) → second-review+
This looks like what I want, thanks!
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.