Closed Bug 364686 Opened 14 years ago Closed 13 years ago

"ASSERTION: shouldn't use unconstrained widths anymore" with img in merror

Categories

(Core :: MathML, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: rbs)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase, Whiteboard: [dbaron-1.9:RwCr])

Attachments

(1 file)

169 bytes, application/xhtml+xml
Details
Loading this testcase causes:

###!!! ASSERTION: shouldn't use unconstrained widths anymore: 'availableWidth != NS_UNCONSTRAINEDSIZE', file /Users/admin/trunk/mozilla/layout/generic/nsHTMLReflowState.cpp, line 214
Attached file testcase
So the issue is that nsMathMLContainerFrame::ReflowForeignChild does:

986       nsSize availSize(NS_UNCONSTRAINEDSIZE, NS_UNCONSTRAINEDSIZE);
987       nsLineLayout ll(aPresContext, aReflowState.mSpaceManager,
988                       aReflowState.parentReflowState);
989       ll.BeginLineReflow(0, 0, availSize.width, availSize.height, PR_FALSE, PR_FALSE);
990       PRBool pushedFrame;
991       ll.ReflowFrame(aChildFrame, aStatus, &aDesiredSize, pushedFrame);
992       NS_ASSERTION(!pushedFrame, "unexpected");
993       ll.EndLineReflow();

That availSize needs to be fixed, basically.  Is there a reason it wouldn't just be aReflowState.mComputedWidth?
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Whiteboard: [dbaron-1.9:RsRwCr]
Whiteboard: [dbaron-1.9:RsRwCr] → [dbaron-1.9:RwCr]
WFM on trunk.  It's possible that this is due to MathML being mostly broken on trunk, so let's get this into the test suite.
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.