Time zone selection list unnecessarily long, hard to find useful time zone reference

RESOLVED DUPLICATE of bug 367893

Status

defect
RESOLVED DUPLICATE of bug 367893
13 years ago
12 years ago

People

(Reporter: gessel, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Is dawson's creek PT, ET, CT?  Or imaginary time?  Time zone selection should use a customizable "favorites" tab with user-named time zones (e.g. "dawson's creek") or a complete list of standard names/and or graphic selection tool such as this nice graphic http://www.worldtimezone.com/. The gigantic list of every real and imaginary city in the world is not particularly useful and problematic for people who regularly change time zones.   

Reproducible: Always

Steps to Reproduce:
1. go to time zone tab
2. Try to find a reference to your time zone
3. laugh at dawson's creek

Actual Results:  
Be frustrated not knowing if the city you've chosen is in a real time zone

Expected Results:  
Find a list of standard time zone names like "Eastern, Central, Pacific, GMT" etc.
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [qa discussion needed]
Version: unspecified → Trunk

Comment 1

12 years ago
Good points here.  A better timezone picker was implemented in the prototype event dialog (you can get to it by downloading the lightning-wcap.xpi (sorry it only works in lightning at the moment). But for the next release we are moving some of the prototype features into the core dialog.  So, please see the newsgroup link in bug 367893 to add to the general discussion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Whiteboard: [qa discussion needed]
Duplicate of bug: 367893
You need to log in before you can comment on or make changes to this bug.