no way to support undoing Cmd+W on last tab on Mac

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: mconnor, Unassigned)

Tracking

({pp, regression})

2.0 Branch
x86
Mac OS X
pp, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
The changes in bug 348031 mean that when I close the last tab accidentally, I have no way of restoring that tab, unlike all of the other tabs.  Short of implementing  full undo close window UI/functionality, that change makes it impossible to get that last tab (or any other tab in that window) back if accidentally closed.

Bug 348031 comment 18 points out the problem here, which is that unlike on other platforms, there's no way to ensure that tab closing is relatively safe.  With the tabstrip always showing, I can use Cmd+W freely, and Cmd+Shift+T to get things back if I go too far.  Now I have to be very careful and slow down, which is a usability hit.  While I understand that there is an inconsistency between our behaviour and that of other Mac browsers, the ability to reopen closed tabs trumps whatever minor benefit always showing the tab bar has for people who want Cmd+W to close unconditionally.

I don't think we should have taken the change for 2.0.0.1 without a full understanding of the UE impact, but its obviously too late for that.  I'm not too keen on flipping behaviour in three straight releases, but I'm leaning that way.
I don't use tab close undo very often, so I don't personally care about this issue, but I can see it might be frustrating for some people.

IMHO the correct solution to this problem is to make it possible to undo closing a window as well as a tab.  Reverting the fix to make the UI work consistently with other browsers is a backward step we shouldn't take.
OK, somehow I totally miswrote my last comment.  It should say "Reverting the fix will make the UI work inconsistently with other browsers,w hich is a backward step we shouldn't take."
(Reporter)

Comment 3

11 years ago
So a minor inconsistency trumps dataloss?  Adding undo close window isn't viable/appropriate on the branch, and I'm not sure we want the footprint/UI to enable it just to fix this case on trunk, but those are two separate discussions.
Some people's definition of "minor inconsistency" may vary from mine; I don't consider this to be minor.  The change made in 2.0 was incredibly irritating.  I don't consider not being able to reopen the window once closed to be data loss.  It's working the same way it always did in the past.  That's not a bug; that's returning to previous behavior that many people preferred.
(Reporter)

Comment 5

11 years ago
Once we shipped it in Firefox 2, it became the baseline behaviour.  Having it not work anymore in 2.0.0.x is a regression, despite it matching 1.5's behaviour.  Just because it wasn't in 1.5 doesn't mean we can drop it without consequence.

There was a simple workaround for your irritation, which was to not always show the tab bar.  There is no simple workaround for this case, however.  And accidentally closing a tab is definitely losing data, which is why we wanted to allow reopening tabs, because people were losing data.  The last tab is just as valuable as any other tab, whether you think its an acceptable dataloss case is separate from whether its dataloss...

Comment 6

11 years ago
how are accidental closed tabs any more dataloss than accidental closed windows?  it seems to me that either both are dataloss and must be dealt with (reopening windows?), or neither are.
Not always showing the tab bar is the thing that's annoying in this case though.  Having your content bounce up and down as you open and close tabs is really rough on the eyes when you're trying to read stuff.

Comment 8

11 years ago
Personally, I think you should be able to undo closing a tab regardless of whether or not the window that it was originally in is still open.

But if that would be too hard to implement at this time, why not just have a dialog that warns people that they're about to lose their closed tab history, and include a "Never show this again" button?

Updated

11 years ago
Flags: wanted1.8.1.x+

Comment 9

11 years ago
can't agree with eric more here... it's a shame this minor issue caused the reversion of a fundamental command... for the third straight release.

Updated

11 years ago
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore

Comment 10

11 years ago
Can this please be eliminated so that bug 348031 can be checked in again? I know several Mac users who were very irritated by the change in behavior from 1.5 to 2.

Comment 11

11 years ago
Since the patch to bug 348031 has been backed out, this bug as filed has become WORKSFORME with Firefox 2.0.0.2.

If you want full Undo Close Window capacity or any other solution to undo closing the last tab when the window is closed with it (bug 354894 might help, though that change could get optional for Macs with bug 382006), please file a new bug for all platforms.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0 Branch
Flags: wanted1.8.1.x+

Comment 12

10 years ago
Has any progress been made to fix this, particularly in the 3.0.0 builds?
You need to log in before you can comment on or make changes to this bug.