Last Comment Bug 365333 - messages database discrepancy / thread display does not match database / message list
: messages database discrepancy / thread display does not match database / mess...
Status: RESOLVED INCOMPLETE
[closeme 2009-07-14] dupeme
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: 1.8 Branch
: x86 Linux
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-29 08:21 PST by Jérôme Bouat
Modified: 2009-08-20 05:53 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
the inbox discrepancy (30.33 KB, image/png)
2006-12-29 08:24 PST, Jérôme Bouat
no flags Details
the fake message in spam folder (32.66 KB, image/png)
2006-12-29 08:26 PST, Jérôme Bouat
no flags Details
the corrupted Inbox.msf file (I archived it) (17.60 KB, application/octet-stream)
2007-01-07 06:32 PST, Jérôme Bouat
no flags Details

Description Jérôme Bouat 2006-12-29 08:21:23 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.9) Gecko/20061222 Firefox/1.5.0.9
Build Identifier: version 1.5.0.9 (20061206)

* My inbox folders summary tell I have 7 new messages
but displaying the content shows nothing.

* I always a message in the spam folder. It appear again even if I delete it.
The message has Epok date (1970), no subject and no message body.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Jérôme Bouat 2006-12-29 08:24:09 PST
Created attachment 249922 [details]
the inbox discrepancy

Left pane tell there are 7 new messages
but right pane shows nothing.
Comment 2 Jérôme Bouat 2006-12-29 08:26:05 PST
Created attachment 249923 [details]
the fake message in spam folder

If I delete this message, if appear again the next time I select the spam folder.
Comment 3 Magnus Melin 2006-12-29 12:51:18 PST
The ghost message is bug 209501 

The inbox issue: are you sure there are mails there? It's likely that it just shows wrong count. Go into your profile folder, and delete the .msf for the Inbox. <http://kb.mozillazine.org/Profile_folder> 

Does that help?
Comment 4 Jérôme Bouat 2006-12-30 04:04:13 PST
I deleted ~/.thunderbird/con51kno.default/Mail/Local Folders/Inbox.msf
and the 7 message could be displayed in the right pane.

I mean I will switch back to Evolution until Thunderbird become reliable.
Comment 5 Magnus Melin 2006-12-30 04:23:50 PST
->WFM since deleting the .msf file made the msgs show. 
Comment 6 Jérôme Bouat 2006-12-30 05:32:16 PST
No, I'm not agree. Why Inbox.msf has been corrupted ? This is a bug.
Comment 7 Magnus Melin 2006-12-30 06:33:38 PST
Yes, but unless you can reproduce the problem, there is not much to do about it...
Comment 8 Jérôme Bouat 2006-12-30 06:52:33 PST
Maybe you should investigate you code.

Have you read the no-well formed '*.msf' files in order to understand what happened ?

If you don't want to watch it, please wait 2 years before closing this bug.
Comment 9 Magnus Melin 2006-12-31 03:31:52 PST
You haven't attached any malformed .msf files. Even if you had, I don't think reading it is a very likely way to find out what happened.

Keeping a bug "open" for the sake of it serves nobody's interests.
Comment 10 Jérôme Bouat 2007-01-07 06:32:36 PST
Created attachment 250750 [details]
the corrupted Inbox.msf file (I archived it)
Comment 11 Jussi Sirpoma 2007-02-22 01:18:37 PST
I think this is a duplicate of bug 358821.
Comment 12 Tom Metro 2007-09-05 18:57:22 PDT
(In reply to comment #0)
> * My inbox folders summary tell I have 7 new messages
> but displaying the content shows nothing.

This is a fairly easy to reproduce problem, under the right circumstances. I see it all the time. It happens when you have a process other than Thunderbird modify the mailbox, and the .msf index gets out of synch.

(I have a mailbox I use as an inbox that receives messages from another process. On UNIX, Mozilla makes provisions for this using what they call a "move mail" account. But they provide no equivalent capability in the Windows builds (which I'm using), so I'm stuck with frequently needing to regenerate the index. Fortunately recent releases have added a button to the folder property dialog, saving the effort of exiting, deleting the .msf, and restarting.)


(In reply to comment #6)
> Why Inbox.msf has been corrupted ? This is a bug.

Yes, I'd agree it is a bug. The logic that controls when to regenerate the .msf index has some holes. Though they go largely unnoticed by typical users receiving mail via Thunderbird's internal POP3 or IMAP retrieval.

 -Tom
Comment 13 Gary Kwong [:gkw] [:nth10sd] 2009-06-14 03:04:53 PDT
Jerome, still occurs with Thunderbird 3 Beta 2? http://www.mozillamessaging.com/en-US/thunderbird/3.0b2/
Comment 14 Jérôme Bouat 2009-06-14 14:33:45 PDT
It still occur on 2.0.0.21 (20090318) version.

I will not test a Beta release with my real data.
Comment 15 Wayne Mery (:wsmwk, NI for questions) 2009-06-25 22:06:41 PDT
(In reply to comment #14)
> It still occur on 2.0.0.21 (20090318) version.
> I will not test a Beta release with my real data.

Please note that if you are imap, using a trunk build poses virtually no risk to your data. But if you feel you can't test now, I would strongly recommend testing beta 3 when it comes out.

Given deleting .msf file corrects the display, this hints ata dupe. But difficult to nail strictly by symptoms and without testing the latest development builds.
Comment 16 Joshua Cranmer [:jcranmer] 2009-08-20 05:53:47 PDT
RESO INCO due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.

Note You need to log in before you can comment on or make changes to this bug.