Closed Bug 365677 Opened 13 years ago Closed 13 years ago

Opening ics-file breaks export selection

Categories

(Calendar :: Import and Export, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aryx, Assigned: jminta)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a2pre) Gecko/20070102 Calendar/0.4a1 - Build ID: 2007010203

Later, export selection was always messed up.

Reproducible: Always

Steps to Reproduce:
1.Start Sunbird.
2.Open a ics-file with events, it should be added to the calendars list.
3.Go in unifinder to the top event, click on it and scroll the list down with alt+pagedown
4.Try 'File > Export selection'
Actual Results:  
Export selection was disabled (grey).

Expected Results:  
Export selection should be enabled (black).

After first time seeing this problem, all went fine after a restart of sunbird. Now 'Export selection' seems to be always disabled.
I can confirm this on Mac OS X 10.4.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a2pre) Gecko/20070102 Calendar/0.4a1

BuildID:2007010203
Status: UNCONFIRMED → NEW
Ever confirmed: true
Because we pass in |true| to the views (to avoid an infinite loop), the views never fire a select event, and the menuitems that depend on selection never get updated.  This patch manually makes the call.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #250780 - Flags: second-review?(mvl)
Attachment #250780 - Flags: first-review?(lilmatt)
Comment on attachment 250780 [details] [diff] [review]
call onSelectionChange

r=lilmatt
Attachment #250780 - Flags: first-review?(lilmatt) → first-review+
Blocks: 358969
Blocks: 352020
Blocks: 353700
Comment on attachment 250780 [details] [diff] [review]
call onSelectionChange

r2=mvl
Attachment #250780 - Flags: second-review?(mvl) → second-review+
Whiteboard: [needs checkin]
Just confirming:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070116 Calendar/0.6a1

BuildID:2007011603

So Export Selection is greyed out until i select ALL of the events with Ctrl-A in unifinder (****/ctrl clicking with mouse didn't work), after which point it's not greyed out, even with just one event selected, and export selection works as expected.
patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [needs checkin]
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070214 Calendar/0.4a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.