All users were logged out of Bugzilla on October 13th, 2018

Frame content loads in another window

RESOLVED DUPLICATE of bug 263160

Status

()

--
major
RESOLVED DUPLICATE of bug 263160
12 years ago
11 years ago

People

(Reporter: asrail, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Created attachment 250241 [details]
Screenshot showing the normal content and the strange window

First, I should mention this bug is not reproducible, even it happens almost every day with me.

Sometimes the content of a frame (maybe the HTML frame or some frame or iframe inside it) is loaded in another window.
This window is a strange window, it does not hold events the same way as the normal windows. If I click to close the window, instead of closing the window, the whole app looses the connection to the display and I see this error message:
"The application 'Gecko' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application."

The tab where the content should be loaded stops updating the graphics and the new window gets a strange way of interacting. You can click some things, but it looks like some things are out of place. Sometimes the content return to its place and the strange window disappears.

There is an attachment showing the bug happening in just one frame.


This bug happened in several different web pages (as http://broffice.org and http://mail.google.com), but as I've said before, it is not reproducible, so, don't try opening some of these pages and expecting the bug to happens.


It usually occurs after a few hours of use, after to having a lot of tabs opened.


I've take the liberty to add a video to Youtube showing the interaction with these windows and showing what happens when trying to close one of them:
http://www.youtube.com/watch?v=st6Dkz2i5LI
(Reporter)

Comment 1

12 years ago
I don't use any extensions, neither themes or language packs.

Every one of these windows you've seen (except chatzilla and the browser) where opened while loading gmail.
You can see the gmail tab, where the content should be, don't being updated.

Usually just one window is opened, and sometimes the focus return to its place. In the case shown in the video, the content where jumping from one of the eight windows to another one.


Raising severity to major.
Severity: normal → major

Updated

12 years ago
Duplicate of this bug: 365733
(Reporter)

Updated

12 years ago
Component: Tabbed Browser → Layout
QA Contact: tabbed-browser → layout

Comment 3

11 years ago
I think this is a dupe of bug 263160 ; if you disagree, please comment, thanks!
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263160
You need to log in before you can comment on or make changes to this bug.