Closed Bug 366013 Opened 16 years ago Closed 15 years ago

Unable to print an image in a popup window without menus visible

Categories

(Firefox :: Menus, defect)

2.0 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 26353

People

(Reporter: heikki.y, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

There seems to be a problem with Mozilla Firefox when a website opens an image in popup window without displaying the menus and toolbars of Firefox. At the moment I am unable to print the image at all because there is no way to get the print dialog opened except for pressing the Print scrn button from your keyboard.

It would be nice if there would be a Print Image context menu item which would allow the user to print the picture easily through the menu.

Reproducible: Always

Steps to Reproduce:
1. Open a popup page without toolbars and which contains only a image.
2. Try to print the image.
Actual Results:  
There is no easy way to print the image except through the keyboard.

Expected Results:  
There should be a way to start printing through the menus as usually printing is started in Windows.
Version: unspecified → 2.0 Branch
This bug is more general in that *any* image or text url opened with javascript into a new browser window without toolbars, has no way of printing it via the right-click context menu. Internet Explorer has a print option in its right-click
popup menu.

Selecting the tools|options setting for opening the new page in a new tab instead of a new window does *not* make all pages open in a new tab.
i think that this is bug 26353
there should be some way to show chrome on chromeless windows
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 26353
You need to log in before you can comment on or make changes to this bug.