Racial epithets should not be included in spelling suggestions

RESOLVED FIXED

Status

()

Core
Spelling checker
--
enhancement
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Ted Bedwell, Assigned: Scott MacGregor)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 1.5.0.9 (20061207)

I was not surprised, when writing referencing Winnie the Pooh, to see that the default dictionary did not include the word "Tigger". I was surprised, to say the least, to see that the top suggestion for replacing the misspelling is "nigger". I'm all for a comprehensive dictionary, but it should not suggest offensive words as potential  spelling corrections. Particularly when an end-user does not have an easy way to suppress particular words as suggestions.

I've noticed that while the word "****" is not flagged as a misspelling, neither is it suggested as a potential correction for the intentionally misspelled "guck". The same logic should apply to racial epithets.


Reproducible: Always

Steps to Reproduce:
1. Compose an email message in Thunderbird
2. Enter the word "Tigger" followed by a space.
3. right clik / control-click etc.. to engage the context menu
4. observe the spelling alternatives
Actual Results:  
The first suggestion is the word "nigger"

Expected Results:  
No racial epithets are presented as spelling options.
(Reporter)

Comment 1

12 years ago
Created attachment 250627 [details]
Screenshot

Attaching a screenshot

Updated

12 years ago
Component: Message Compose Window → Spelling checker
Product: Thunderbird → Core
QA Contact: message-compose → spelling-checker
Version: unspecified → 1.8 Branch

Updated

12 years ago
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
(Reporter)

Updated

12 years ago
Summary: Racial Epithets should not be included in the default dictionary → Racial Epithets should not be included in spelling suggestions

Comment 2

12 years ago
> I've noticed that while the word "fuck" is not flagged as a misspelling

There is no logic to handle bad words. guck has too many possible corrections for it to show up in the top 5: try "fck". The library we use has no ability to know about words that shouldn't be suggested. See bug 319778 for the new library we would like to use, although I doubt it has this capability either.

Comment 3

12 years ago
The comments in the bug Brett Wilson linked to say that hunspell can refrain from suggesting taboo words as corrections for misspellings: the topic of this bug.

Updated

12 years ago
Depends on: 319778

Updated

12 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
This may need a separate bug for Camino, since we use a different spelling dictionary (the OS dictionary rather than MySpell).
Summary: Racial Epithets should not be included in spelling suggestions → Racial epithets should not be included in spelling suggestions

Comment 5

11 years ago
However, I do not think hardwiring into the spell checking that offensive words should be filtered out of the suggestions is desirable. If I want to use offensive words, that is my choice. Depending on the context, they may very well not be offensive at all. The spell checker can’t and shouldn’t decide what’s right or wrong (in the ethics sense), given that it has no understanding of the context, and also that it has no right to impose moral values upon me.

As a side note, while ‘nigger’ may be a very offensive word in America, in the Netherlands and probably Europe in general we are much more relaxed about that. Its Dutch equivalent doesn’t really have a racist association going with it. Or at least not a very strong one, it’s not a taboo word like in the US. Hence, a discussion with Dutchmen involved may very well contain various references to niggers without it having any offensive intention. (Of course, every time an American is involved in the discussion, you’ll get an annoyingly shocked reaction the first time they hear it.)


~Grauw

Comment 6

11 years ago
This is only about not unnecessarily exposing the user to words commonly considered crass or offensive, not about preventing their use or imposing moral values.  If they're already "commonly" considered crass or offensive, it would seem the judgment has already been made by that society.  As far as compromises go, I think this is an excellent one.

Nothing stops you from using offensive words -- you just have to know how to spell them correctly ;-).  Is that so much of a burden?

Comment 7

11 years ago
Yes it is a burden, they are treated unfairly compared to other words.

There is a group of people in America who get all hysteric and politically correct whenever they hear or see a word that they deem taboo, and woe he who refers to it by anything but ‘the n-word’ or ‘the f-word’ (that is just so silly!). However, these words by themselves are harmless and not offensive, it is the context in which they are used and the fact that they are used by a human with a negative intent.

A computer should just be able to do its work, and if nigger word is spelled incorrectly (e.g. niggre) then the thing should be able to do its work and suggest the proper spelling, nigger. Currently, for the spelling mistake I just made, Firefox correctly suggests nigger (and niggle) as a suggested correction.

As for society making a judgement, note that en-US is not only used in America. Are you implying people should not speak or write en-US without also inheriting the American cultural values? In the Netherlands a lot of people speak American English on a frequent basis.

Also, it seems to me that such a setting would be made globally, and thus also apply to the Dutch dictionary, where it would definitely not reflect the Dutch society.

So, I object very strongly to this on a principal basis. People who get offended by spelling suggestions should just get over themselves, if you don’t mind me saying.


~Grauw

Comment 8

11 years ago
(And by filtering them out of the suggestions, you *are* imposing moral
values. That is what this bug does.)

Comment 9

11 years ago
There are also people who argue that racial epithets should not be listed in dictionaries. I hope you agree that that is ridiculous. This falls in the same category.

(Sorry for spamming three messages.)
(In reply to comment #7)
> There is a group of people in America who get all hysteric and politically
> correct whenever they hear or see a word that they deem taboo, and woe he who
> refers to it by anything but ‘the n-word’ or ‘the f-word’ (that is just
> so silly!). However, these words by themselves are harmless and not offensive,
> it is the context in which they are used and the fact that they are used by a
> human with a negative intent.

I don't want to hear that word, even if it comes from someone who doesn't want to do any harm. The context will halfway always be a historical one, which makes the non-documentary use by someone who isn't affected itself offending. I'm far from "a group of people in America", by the way.

> A computer should just be able to do its work, and if nigger word is spelled
> incorrectly (e.g. niggre) then the thing should be able to do its work and
> suggest the proper spelling, nigger. Currently, for the spelling mistake I just
> made, Firefox correctly suggests nigger (and niggle) as a suggested correction.

If you wanted to type "niggle" and if you found the n-word offending, you wouldn't want to see that as a suggestion. That's what this bug is about. As a tolerant person, you will accept that, even if you personally think political correctness is pointless, stupid, boring, an US American disease or whatever.

(In reply to comment #8)
> (And by filtering them out of the suggestions, you *are* imposing moral
> values. That is what this bug does.)

So what?

(In reply to comment #9)
> There are also people who argue that racial epithets should not be listed in
> dictionaries. I hope you agree that that is ridiculous.

And that's what this bug is not about. Tactfulness is not censorship; it's not even the same category.

Comment 11

11 years ago
In case you guys didn't notice: The MySpell engine (from OpenOffice 1.x) is beeing replaced with HunSpell (from OO 2.x).
See Bug 319778

OpenOffice 2.1 doesn't even suggest "nigger" if you type "tigger". Thus this change will be part of Mozilla anyway. So please stop spamming.
This bug already depends on bug 319778. The change is on the way, yet Laurens Holst is free to express his opposing opinion. And I am free to respond. In fact, since the actual work is done in another place, this bug doesn't serve any other purpose.

Ironically, your comment and this one can most likely be considered spam. I suggest we stop that and return to the topic. (By that I don't mean to force you to listen or even participate, by the way.)
Fixed by the Hunspell landing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Duplicate of this bug: 393615

Comment 15

11 years ago
I want say: browser should not force any behaviour on users. Including deciding if users want to use word nigger or not.
We have excellent russian proverb for it:
There is a ass, but there isn't word for it.
(Zhopa est', a slova net) 
I think the solution of having the word in the dictionary but not recommending it as a correction is an adequate compromise. Anyway, this bug is resolved, so let's not beat a dead horse.
You need to log in before you can comment on or make changes to this bug.