Note: There are a few cases of duplicates in user autocompletion which are being worked on.

tabbox appear in incorrect place and are insensitive when "hidden" attribute changed

RESOLVED DUPLICATE of bug 261826

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 261826
11 years ago
11 years ago

People

(Reporter: Pete Morgan, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.46 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

In my app I have four tabs, the last two are hidden. When these are enabled they appear in the incorrect order as 1,3,2,4, even tough in code they are correct.

Also if if the tabs are enabled with tab.setAttribute('hidden','false') instead of tab.hidden = false then they are NOT sensitive to clicks.



Reproducible: Always

Steps to Reproduce:
1. Create a tabbox with 4 tabs with hidden="true"
2. Run js to un-hide tabs
3. When unhidden they appear in the "incorrect" order
4. If un-hidden with setAttribute('hidden') then they do not respond to clicks and an error

Actual Results:  
If tab is unhidden with setAttribute() then the following error reported

Error: aNewTab has no properties
Source File: chrome://global/content/bindings/tabbox.xml
Line: 336


Expected Results:  
Tabs just to appear in the correct order

Attached is test case
(Reporter)

Comment 1

11 years ago
Created attachment 250682 [details]
Tabs in incorrect order with error

Updated

11 years ago
Keywords: testcase
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 261826
You need to log in before you can comment on or make changes to this bug.