Crashes in nsDocument::cycleCollection::Traverse

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mak, Unassigned)

Tracking

({crash})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a2pre) Gecko/20070105 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a2pre) Gecko/20070105 Camino/1.2+

Camino trunk nightlies frequently crash in nsDocument::cycleCollection::Traverse(nsISupports*, nsCycleCollectionTraversalCallback&)

Reproducible: Sometimes

Steps to Reproduce:
1. Run Camino for a while. I was using Google Images to get iTunes album art.
2.
3.
Actual Results:  
See attached crash log.


PowerMac dual G5, Mac OS X 10.4.8
(Reporter)

Comment 1

13 years ago
Posted file Crash log
Offhand, sounds like possible fallout from the XPCOM GC landing (bug 333078) yesterday (although there's a lovely non-virtual thunk to the appshell, too).
Keywords: crash
Attachment #250700 - Attachment mime type: application/octet-stream → text/plain
I've committed a slightly more real fix -- still a band-aid -- to the culprit class nsImageDocument. Can you confirm that the bug is suppressed by this? 

Tracking the long-term problem back over in bug 333078.
I reproduced this bug on Windows too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
Component: General → XPCOM
Product: Camino → Core
QA Contact: general → xpcom
Version: unspecified → Trunk
(In reply to comment #3)
> Tracking the long-term problem back over in bug 333078.

Just a suggestion: resolve the humongo "land cycle collector" bug (333078) now, since it is in fact landed, and file followup bugs (or use bugs like this one) for the remaining issues. You can mark them as blocking bug 333078 to link them to the major bug. It makes it much easier to identify specific issues without having to dig through a lot of comments/patches in one big bug, and "one issue per bug" especially helps when people are later trying to understand changes and why they were made.
(Reporter)

Comment 7

13 years ago
I am no longer getting crashes with today's nightly trunk build.
Fixed again -- more correctly -- with subsequent patch in 366063. Please reopen
if you are still seeing it.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.