Does not submit from JavaScript on page onunload event fires

RESOLVED DUPLICATE of bug 356923

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 356923
12 years ago
12 years ago

People

(Reporter: Ilija, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

I have javascript on page that asks the user for Save changes when page is closed? The saving includes submit on the same page. The saving mechanism works just fine when whole browser is closed, but when only a tab is closed the event onunload fires but the javascript does not submit the page.

Reproducible: Always

Steps to Reproduce:
1.Make javascript that submits the page
2.Call the script on page onunload event
3.Close the whole browser
4.See if data has been submited to server
5.Open the same page again and close ONLY the tab this time
6.See if data has been submited to server
7.Data will NOT be sent to server.


Expected Results:  
Data should be always sent to server on page exit
Assignee: nobody → general
Component: General → DOM
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356923
You need to log in before you can comment on or make changes to this bug.