Last Comment Bug 366398 - On Darwin, Makefile.ref using libtool incorrectly builds libjs.so as a static library
: On Darwin, Makefile.ref using libtool incorrectly builds libjs.so as a static...
Status: RESOLVED FIXED
: fixed1.8.0.10, fixed1.8.1.2
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All Mac OS X
: -- minor (vote)
: ---
Assigned To: Brian Crowder
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 97954
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 20:36 PST by Brian Crowder
Modified: 2007-02-06 20:11 PST (History)
2 users (show)
bob: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1 (1.57 KB, patch)
2007-01-08 21:32 PST, Brian Crowder
benjamin: review+
dveditz: approval1.8.1.2+
dveditz: approval1.8.0.10+
Details | Diff | Splinter Review
patches only jsatom.c (839 bytes, patch)
2007-02-05 08:18 PST, Brian Crowder
crowderbt: review+
Details | Diff | Splinter Review

Description Brian Crowder 2007-01-08 20:36:13 PST
This can be proven by using the "file" command on the .so output, or by diffing libjs.a versus libjs.so; they are identical files.

Should instead use gcc with -dynamiclib option, and the result should be named libjs.dylib instead of libjs.so.  Or, this bug should go away when I finally get around to doing a configure script in bug 97954
Comment 1 Brian Crowder 2007-01-08 21:32:04 PST
Created attachment 250930 [details] [diff] [review]
fix v1

In Darwin.mk:  No longer using libtool, instead using $(CC) -dynamiclib (this seems to be a recommendation of the Mac OS X developer docs).  Also, in jsatom.c, two debug variables had to be made static to correct linker whining.
Comment 2 Brian Crowder 2007-01-08 21:33:03 PST
Comment on attachment 250930 [details] [diff] [review]
fix v1

Dunno if you're the right reviewer for this or not, Brendan.  Who else should I consult for Mac OS X build-advice?
Comment 3 Brian Crowder 2007-01-24 09:03:26 PST
Comment on attachment 250930 [details] [diff] [review]
fix v1

Trying bsmedberg on review, since this is a build thing (with Makefile.ref, not the main moz/ff build, but there you have it)
Comment 4 Brian Crowder 2007-01-31 13:53:54 PST
Due to some CVS mishaps on my part, this landed in two pieces:
config/Darwin.mk:  1.4
jsatom.c: 3.90
Comment 5 Brian Crowder 2007-02-01 10:41:10 PST
Backed this out, since it causes the branch builds to break.  Why do we have config/ and editline/ ONLY on the main trunk again???

Checking in jsatom.c;
/cvsroot/mozilla/js/src/jsatom.c,v  <--  jsatom.c
new revision: 3.91; previous revision: 3.90
done
Checking in config/Darwin.mk;
/cvsroot/mozilla/js/src/config/Darwin.mk,v  <--  Darwin.mk
new revision: 1.5; previous revision: 1.4
done
Comment 6 Brian Crowder 2007-02-02 12:34:58 PST
Comment on attachment 250930 [details] [diff] [review]
fix v1

The jsatom.c changes from this need to propogate to the branches to prevent build-breakage.  It's a simple matter of making two variables static.
Comment 7 Daniel Veditz [:dveditz] 2007-02-02 13:42:29 PST
Comment on attachment 250930 [details] [diff] [review]
fix v1

approved for 1.8/1.8.0 branches, a=dveditz for drivers
Comment 8 Jay Patel [:jay] 2007-02-04 23:17:51 PST
Crowder:  What's left to do here?  Can you get this landed on the branches asap (if the issues that resulted in the previous backout have been resolved)?
Comment 9 Brian Crowder 2007-02-05 08:18:39 PST
Created attachment 254038 [details] [diff] [review]
patches only jsatom.c

This is -just- the jsatom.c fix (making two debug variables static), which I am landing on the branches.
Comment 10 Brian Crowder 2007-02-05 08:25:17 PST
1.8:
Checking in jsatom.c;
/cvsroot/mozilla/js/src/jsatom.c,v  <--  jsatom.c
new revision: 3.65.4.6; previous revision: 3.65.4.5
done


1.8.0:
Checking in jsatom.c;
/cvsroot/mozilla/js/src/jsatom.c,v  <--  jsatom.c
new revision: 3.65.4.1.4.2; previous revision: 3.65.4.1.4.1
done

Trunk:
Checking in jsatom.c;
/cvsroot/mozilla/js/src/jsatom.c,v  <--  jsatom.c
new revision: 3.92; previous revision: 3.91
done
Checking in config/Darwin.mk;
/cvsroot/mozilla/js/src/config/Darwin.mk,v  <--  Darwin.mk
new revision: 1.6; previous revision: 1.5
done
Comment 11 Jay Patel [:jay] 2007-02-05 11:36:33 PST
Adding fixed1.8.x.x keywords since this has landed on the branches.

Note You need to log in before you can comment on or make changes to this bug.