Last Comment Bug 366606 - JS Assertion with Firebug 0.4.1 on branch build
: JS Assertion with Firebug 0.4.1 on branch build
Status: RESOLVED FIXED
: fixed1.8.0.10, fixed1.8.1.2
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla1.9alpha1
Assigned To: Brendan Eich [:brendan]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 13:42 PST by Robert Sayre
Modified: 2007-01-17 04:12 PST (History)
3 users (show)
bob: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
JS stack and C stack (9.29 KB, text/plain)
2007-01-10 13:42 PST, Robert Sayre
no flags Details
fix assertion (479 bytes, patch)
2007-01-10 15:47 PST, Brendan Eich [:brendan]
sayrer: review+
Details | Diff | Splinter Review

Description Robert Sayre 2007-01-10 13:42:08 PST
Created attachment 251110 [details]
JS stack and C stack

I'm hitting this assertion pretty regularly with Firebug 0.4.1 in a branch build.

Assertion failure: scope->ownercx == cx, at /Users/sayrer/bonecho/mozilla/js/src/jslock.c:1286
Comment 1 Brendan Eich [:brendan] 2007-01-10 15:47:50 PST
Created attachment 251130 [details] [diff] [review]
fix assertion

This applies to the trunk, the 1.8 branch, and the 1.8.0 branch.

/be
Comment 2 Brendan Eich [:brendan] 2007-01-10 16:02:47 PST
Thanks to sayrer for lengthy gdb over irc fun, including running into what seems to be a Macbook Pro CPU cache coherence prob (perhaps gdb's fault?).

/be
Comment 3 Brendan Eich [:brendan] 2007-01-10 16:14:52 PST
(In reply to comment #2)
> Thanks to sayrer for lengthy gdb over irc fun, including running into what
> seems to be a Macbook Pro CPU cache coherence prob (perhaps gdb's fault?).

(Or more likely Mac OS X's fault...)

/be
Comment 4 Robert Sayre 2007-01-10 16:43:20 PST
Comment on attachment 251130 [details] [diff] [review]
fix assertion

This patch suppresses the assertion for me.
Comment 5 Brendan Eich [:brendan] 2007-01-10 16:48:26 PST
Fixed everywhere -- don't feel the need to get approval for an assertion fix.

trunk: js/src/jslock.c rev 3.61
1.8:   js/src/jslock.c rev 3.55.20.1
1.8.0: js/src/jslock.c rev 3.55

/be

Note You need to log in before you can comment on or make changes to this bug.