Images that are downscaled in the browser from their original size are rendered in a very bad quality

RESOLVED DUPLICATE of bug 98971

Status

()

--
major
RESOLVED DUPLICATE of bug 98971
12 years ago
12 years ago

People

(Reporter: helke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I recently tested it with version 2.0.0.1 but I rember that version 1.x had the same problems. Many images are noticably degraded in quality if they are downsized in the bwrowser. In some even as bad that the images are essentially destroyed. You can see such a problem in my first example.

Reproducible: Always

Steps to Reproduce:
1. See any webpage that forces the browser to downscale an image and compare it with a downscaled version of the image done by properly working software. Almost every photo software will do a correct job. In some programs you have to configure the the use of a better downscaling algorithm for on the fly downscaling for your display.

You can see two examples here: 
http://www.flickr.com/groups/highres_favorites/discuss/72157594472370749/

Actual Results:  
Getting even more disgusted at the firefox downscaling performance after seing the horrible results in my first example.

Expected Results:  
The image quality I see for downscaled images in just about every other photo program or the Opera web browser.
 
It should have used an more intelligent downscaling algorithm than the one actually employed here.

Opera 9.02 does a good downscaling job. There is no difference visible compared to the downscaled version provided by flickr.

I wonder why nobody else discovered this major design flaw jet. I probably should have written this bug report 15 months ago when I first noticed the problems with jagged lines in photos shown by firefox.

And what is Microsoft thinking what they are doing? Internet Explorer has the same  problem of producing substandard results for downscaled images.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98971
You need to log in before you can comment on or make changes to this bug.