Last Comment Bug 366886 - Output inside of message doesn't work right
: Output inside of message doesn't work right
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: xforms
: Stephen Pride
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-12 19:17 PST by aaronr
Modified: 2008-11-21 10:27 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (2.39 KB, application/xhtml+xml)
2007-01-12 19:19 PST, aaronr
no flags Details

Description aaronr 2007-01-12 19:17:54 PST
When a xf:output is contained inside a xf:message, we aren't building the message properly to take into account the xf:output's value.
Comment 1 aaronr 2007-01-12 19:19:54 PST
Created attachment 251340 [details]
testcase

testcase that shows the problem.

We also need to verify with the WG how many messages should show.  Should there be two for each change since the select1 and the output are both bound to the changed node and the event bubbles up through the observer node for both?  formsPlayer only shows the message once (I assume for the select1).
Comment 2 aaronr 2007-01-12 19:25:48 PST
We broke something in trunk.  0.7.0.1 on FF2 works pretty much right other than the context for the output is lost in the second test.  On trunk we aren't seeing any text whatsoever in the xf:message.  Probably related to bug 363516.  But even if it is we need to fix the context issue and verify the number of messages that should appear.
Comment 3 aaronr 2008-11-21 10:27:08 PST
This testcase works for me on the FF3 branch now so closing the bug.

Note You need to log in before you can comment on or make changes to this bug.