Replace "Restore defaults" with something that says what it actually does

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: aryx, Assigned: philor)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9.3a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a2pre) Gecko/20070115 Calendar/0.6a1

Some user expect that Calendar would show the default columns in the default order after clicking at this menu. At the moment, only the default order is restored.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Moving to correct product.
Assignee: nobody → Jan.Varga
Component: Calendar Views → XP Toolkit/Widgets: Trees
Product: Calendar → Core
QA Contact: views → xptoolkit.trees
Version: unspecified → Trunk

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
(Assignee)

Comment 2

8 years ago
It's actually a Toolkit bug, since that's who chose the bad label:

In 1.7, the menuitem at the bottom of the column chooser menu, the menu which lets you show and hide columns, was "Restore natural order" which wasn't terribly clear, other than that it was clearly about order.

Bug 241249 changed the XPFE label to "Reset Column Ordering", but then "per discussion with beltzner" mconnor said to change the Toolkit string to "Restore Defaults".

Despite having commented in bug 241249 several times, wsmwk then forgot that "Restore Defaults" means "Restore something you don't change in this menu to its default, but don't change the thing that you do change in this menu to its default" and filed bug 463396, and none of us realized that it hadn't actually ever done what the label says it does.

Then justdave filed bug 504989, pointing directly at a regressing bug which actually didn't change a thing, because it seemed so obvious that we wouldn't have had a menuitem to restore ordering at the bottom of a menu that changes which columns are shown and hidden without saying that it doesn't change what's shown or hidden, only the order, and none of us realized that it hadn't actually ever done what the label says it does.

Fortunately, since Firefox has hidden the column chooser for nearly all of their trees (about:config is the only one I can think of that shows it), there isn't too much reason to object to those of us who use trees and column choosers wanting to change it to something less confusing.
Assignee: Jan.Varga → philringnalda
Blocks: 504989, 241249
Severity: trivial → normal
Status: UNCONFIRMED → ASSIGNED
Component: XUL → XUL Widgets
Ever confirmed: true
Product: Core → Toolkit
QA Contact: xptoolkit.widgets → xul.widgets
Summary: Replace "Restore defaults" with "Restore default order" for unifinders → Replace "Restore defaults" with something that says what it actually does
Target Milestone: --- → mozilla1.9.3a1
(Assignee)

Comment 3

8 years ago
Created attachment 405207 [details] [diff] [review]
"Restore Column Order"

Try one, "Restore Column Order".
Attachment #405207 - Flags: ui-review?(beltzner)
Attachment #405207 - Flags: review?(gavin.sharp)
Attachment #405207 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

8 years ago
Whiteboard: [needs ui-r]
(In reply to comment #3)
> Created an attachment (id=405207) [details]
> "Restore Column Order"
> Try one, "Restore Column Order".

I like Phil's proposal of comment #3.
We might want to consider that after this bug is fixed (correct label for "Restore Default Column Order" command), there will still be the people of bug 504989 who actually want to have new functionality of "Restore Default Columns".

As I point out in bug 504989, these should be two separate commands (not everyone who wants to re-sort the columms also wants the default set restored).
So we should look at the two labels together:

1) with phil's suggestion, we'd have:
"Restore Column Order" (that doesn't explicitly have "default" in it)
"Restore Default Columns"

2) here's an alternative:
"Restore Default Order" (given that the column picker is all about columns)
"Restore Default Columns"

3) another option
"Restore Default Column Order" (that's least ambiguous, but also quite long)
"Restore Default Columns"

I'm not biased in favor of any of these. Phil, what do you think?
For the second command, we might also consider "Restore Default Column Set", but that just seems to make it longer without adding much.
> As I point out in bug 504989, these should be two separate commands (not
> everyone who wants to re-sort the columms also wants the default set restored).
FTR, that's bug 504989, comment #12.
(Assignee)

Comment 6

8 years ago
Comment on attachment 405207 [details] [diff] [review]
"Restore Column Order"

(In reply to comment #4)
> Phil, what do you think?

I think it's incredibly difficult to get ui-r from the very limited and very busy set of toolkit ui-reviewers, and a bunch of rambling about things that aren't and things that might someday be in a bug about things that are will do absolutely nothing to increase the odds of my ever getting ui-r.
Attachment #405207 - Flags: ui-review?(beltzner) → ui-review?(mconnor)
Comment on attachment 405207 [details] [diff] [review]
"Restore Column Order"

omg, fast turnaround on a ui-r? Shocking.
Attachment #405207 - Flags: ui-review?(mconnor) → ui-review+
(Assignee)

Comment 8

8 years ago
http://hg.mozilla.org/mozilla-central/rev/b71d1f7fbfa3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Whiteboard: [needs ui-r]

Updated

8 years ago
Duplicate of this bug: 547680
You need to log in before you can comment on or make changes to this bug.