Closed Bug 367153 Opened 18 years ago Closed 16 years ago

Event text not readable in calendar view during inline editing (due to unselection)

Categories

(Calendar :: Calendar Frontend, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: berend.cornelius09)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a2pre) Gecko/20070116 Calendar/0.6a1

Event text not readable in calendar view during inline editing if a dark background color is selected for the calendar. This seems to be caused by the fact the the event gets unselected when inline editing starts.

Steps to Reproduce:
1. Go to Calendars tab and select a dark color for this calendar
2. Create some dummy events for this calendar
3. Click event in main calendar view to select it
4. Click event in main calendar view to start inline editing
5. Move cursor and type some text

Actual Results:
Event box is displays black text on dark background.

Expected Results:
Either text is shown with readable color or the event doesn't get unselected when inline editing starts.

Regression range:
  Works in Sunbird/0.4a1 (2007-01-10-03)
  Fails in Sunbird/0.4a1 (2007-01-10-08)
  --> Bug 361211

Previous behaviour:
  Event, normal:         dark background + white text
  Event, selected:       orange background + black text
  Event, inline editing: orange background + black text

Current behaviour:
  Event, normal:         dark background + white text
  Event, selected:       orange background + black text
  Event, inline editing: dark background + black text
Requesting wanted‑calendar0.8 since this is a very annoying and prominent bug.
Flags: wanted-calendar0.8?
Flags: wanted-calendar0.8? → wanted-calendar0.8+
Not going to happen for 0.8.
Flags: wanted-calendar0.8+ → wanted-calendar0.8-
Second try ;-) Requesting wanted‑calendar 0.9 since this is a very annoying and prominent bug.
Flags: wanted-calendar0.9?
Flags: wanted-calendar0.9?
Flags: wanted-calendar0.9+
Flags: wanted-calendar0.8-
Assignee: nobody → Berend.Cornelius
Status: NEW → ASSIGNED
Attached patch patch v. #1 (obsolete) — Splinter Review
textcolor was not inherited from the parent
Attachment #323064 - Flags: review?(philipp)
OS: Windows 2000 → All
Hardware: PC → All
Version: Trunk → unspecified
Comment on attachment 323064 [details] [diff] [review]
patch v. #1

r=philipp
Attachment #323064 - Flags: review?(philipp) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.15pre) Gecko/2008053020 Calendar/0.9pre

Error still exists in Multiweek and Month view. In Day and week view it works now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch patch v. #2 (obsolete) — Splinter Review
I aligned the code of both bindings and decided to set the color inline similar to the background-color
Attachment #323064 - Attachment is obsolete: true
Attachment #323385 - Flags: review?(ssitter)
Attachment #323385 - Flags: review?(ssitter) → review?(philipp)
Comment on attachment 323385 [details] [diff] [review]
patch v. #2

I'd prefer to have both the background color and the color in a css style rule, and not inline. That makes the xul code more readable.
Attachment #323385 - Flags: review?(philipp) → review-
Attached patch patch v. #3Splinter Review
I outsourced the css rule as Philipp objected
Attachment #323385 - Attachment is obsolete: true
Attachment #323527 - Flags: review?(philipp)
Comment on attachment 323527 [details] [diff] [review]
patch v. #3

r=philipp
Attachment #323527 - Flags: review?(philipp) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH
->FIXED
Status: REOPENED → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → FIXED
checked in lightning 2008081218 and sunbird 20080812 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: