Closed Bug 367170 Opened 13 years ago Closed 13 years ago

Thunderbird crashed when I entered calendar's URL in the Location field

Categories

(Calendar :: Provider: CalDAV, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: omarb.public, Unassigned)

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 

I entered calendar's URL in the Location field when I was trying to create a new calendar. Then Thunderbird crashed

Reproducible: Always

Steps to Reproduce:
1.Select New Calendar (File->New Calendar; Right click on the calendar list, select New, Double click on the calendar list)
2.Select On the network and press next
3.Select CalDAV
4.Enter url: https://cosmo-demo.osafoundation.org:443/home/my_login/
5.Press Next
6.Enter name and select colour
7.Select Next
Actual Results:  
1.Crash
2.After restarting thunderbird there is a new calendar on the list with 'null' name


Thunderbird version 2 beta 1 (20070113)
Lightning build 2007011605
WCAP enabler build 20070116

Report: TB28417505W
I have also WCAP calendar on the list of my calendars. When I delete the null name calendar, WCAP calendar also disappears from the list
Summary: Thunderbird crashes when I entered calendar's URL in the Location field → Thunderbird crashed when I entered calendar's URL in the Location field
I rather doubt that there is a CalDAV collection at the URI specified, though there likely is a DAV collection there: see discussion in bug 355270, of which I believe this is a dupe.
Doesn't crash for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.9a2pre) Gecko/20070116 Calendar/0.6a1. I only see the following error in
console:

Error: this.mPrompter.promptAuth is not a function
Source File: file:///D:/sunbird/js/calUtils.js  Line: 354
Attached patch use nsIAuthPrompt2 (obsolete) — Splinter Review
egads. that mPrompter business *is* a bug which I would swear wasn't there last week; this fixes it. While the patch addresses the problem mentioned in comment #3, I believe it to be unrelated to the initial bug report.
Attachment #251702 - Flags: first-review?(lilmatt)
(In reply to comment #4)
nsIAuthPrompt2 does not seem to exist on mozilla1.8.0 and mozilla1.8 branch, that means it won't work with Thunderbird 1.5, Thunderbird 2.0 or Sunbird 0.4a1.
True, nsIAuthPrompt2 does not exist on branch. But neither does promptAuth, so the code in question won't get called on branch. Patch tested with both current Sb/trunk and Sb/branch.
Comment on attachment 251702 [details] [diff] [review]
use nsIAuthPrompt2

r=lilmatt with a comment added saying "//Trunk only" or something similar so people don't get confused
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #251702 - Flags: first-review?(lilmatt) → first-review+
Attached patch add comment per r1 (obsolete) — Splinter Review
added comment per lilmatt to make it clear we're not attempting to use nsIAuthPrompt2 on branch
Attachment #251702 - Attachment is obsolete: true
Attachment #253714 - Flags: second-review?(jminta)
Comment on attachment 253714 [details] [diff] [review]
add comment per r1

Why does mPrompter2 need to be saved on the object with |this.|?  Why not just use a regular variable?
Attached patch use var not thisSplinter Review
Right you are. Thanks.
Attachment #253714 - Attachment is obsolete: true
Attachment #253721 - Flags: second-review?(jminta)
Attachment #253714 - Flags: second-review?(jminta)
Comment on attachment 253721 [details] [diff] [review]
use var not this

the variable needs to be renamed, since it's not a part of the object anymore.  (m- is reserved for that case.)  r2=jminta with that.
Attachment #253721 - Flags: second-review?(jminta) → second-review+
Patch (with var name changed) checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with lightning 2007020905
Status: RESOLVED → VERIFIED
Whiteboard: [litmus testcase wanted]
Flags: in-litmus?
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.