Closed Bug 367190 Opened 13 years ago Closed 9 years ago

Task list needs more contrast for tasks

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cmtalbert, Assigned: mmecca)

Details

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a2pre) Gecko/20070116 Calendar/0.6a1

The Sunbird task list uses a light gray color to display task titles. This light gray color is displayed on a white/off-white background, and can be hard for people to read.  At the very least, we should allow people the option of changing the display color for tasks, or at best, we should display the tasks with the color of their associated calendar (which is a different bug).

Reproducible: Always

Steps to Reproduce:
1. Create a task
2. Attempt to read it

Actual Results:  
Light gray text on a white background is difficult to read

Expected Results:  
The text vs. the background should have better contrast.

Marking as normal. If people had some mechanism available to change the color then it would be a trivial bug (or perhaps not even a bug at all).
This problem still exists in Lightning 1.0 beta 2.  I have the same problem under Linux when using any theme that has dark menu bars and light menu text.  It seems Lightning is choosing the menu text color for the task list as well as the snooze menu when a task notification pops up.  In the case of the snooze menu, perhaps it should use the menu background color as well, since it is a menu.

I am attaching two screenshots, one of the task list and one of the snooze menu.  In the first screenshot you can see that the task text color matches the menu text color at the top of the Thunderbird window.
The problem with the task view is still present with the default theme on Ubuntu 11.04.
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
The problem is in calendar-task-tree.css:
.calendar-task-tree > treechildren::-moz-tree-cell-text(future) {
    color: MenuText;
}

Ubuntu is using a light grey menu text on a dark menu background.

With this, the text is normally readable:
.calendar-task-tree > treechildren::-moz-tree-cell-text(future) {
    color: WindowText;
}

This could be solved when lightning has it's own gnomestripe theme.
Summary: Sunbird task list needs more contrast for tasks → Task list needs more contrast for tasks
Attached patch patch v1Splinter Review
I think WindowText makes more sense here, and will be consistent with tasks due today that currently use WindowText in bold. I'll request ui-review from whoever is available.
Attachment #540205 - Flags: ui-review?
Attachment #540205 - Flags: review?(philipp)
Comment on attachment 540205 [details] [diff] [review]
patch v1

Codewise r+. Richard, any objections to do this on both linux and windows?
Attachment #540205 - Flags: ui-review?(richard.marti)
Attachment #540205 - Flags: ui-review?
Attachment #540205 - Flags: review?(philipp)
Attachment #540205 - Flags: review+
Comment on attachment 540205 [details] [diff] [review]
patch v1

Review of attachment 540205 [details] [diff] [review]:
-----------------------------------------------------------------

For me this looks good also under Win 7
Attachment #540205 - Flags: ui-review?(richard.marti) → ui-review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/4ccac5d597d4>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-miramar <http://hg.mozilla.org/releases/comm-miramar/rev/d39d127de6cd>
Target Milestone: Trunk → 1.0b4
You need to log in before you can comment on or make changes to this bug.