nginx compatibility feature request

RESOLVED DUPLICATE of bug 316665

Status

()

Bugzilla
WebService
--
enhancement
RESOLVED DUPLICATE of bug 316665
12 years ago
12 years ago

People

(Reporter: Peter Vereshagin, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Nutscrape (CP/M; 8bit)
Build Identifier: 2.22.1

Hello,
We had chosen nginx cause of high load needs.
Later we needed the bug tracking system.
Nginx has no own fastcgi process manager like apache's one. so i handmade the FCGI::Spawn, the multiforked fastcgi application server keeping the %INC between forks launched permanent. And, Nginx  is not able to launch CGI.
It was very strange to see Bugzilla doesn't work in such an environment. The user identification was binded to each fork, not to session cookies.
I needed a hard voodoo on unloading some of the Bugzilla::Whatever between the loop iterations.
So I suspect Bugzilla doesn't apply the mod_perl culture, e.g. not to keep $main::my's and so on.
But should like to see howto on bugzilling the nginx.
Thanks a lot.

Reproducible: Always

Steps to Reproduce:
1.Install Nginx
2.Try to launch Bugzilla at any fastcgi process manager
3.login as admin
4.open bugzilla index page at another browser/computer. Refresh to see you are logged in as admin.
Actual Results:  
Logged in as admin

Expected Results:  
Unlogged in index page

Main reason of fastcgi is nginx, any suggestions ( e.g. the built-in perl handler ) should be the solution.

Comment 1

12 years ago
It sounds like you're asking for FastCGI compatibility, and we won't be doing that, since we already have mod_perl compatibility in the latest CVS code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316665
You need to log in before you can comment on or make changes to this bug.