If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<svg:circle> kills firefox: "cairo-pen.c:323: failed assertion `i < pen->num_vertices'"

RESOLVED FIXED

Status

()

Core
SVG
--
blocker
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(4 keywords)

Trunk
PowerPC
Mac OS X
assertion, crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

233 bytes, application/xhtml+xml
Details
(Reporter)

Description

11 years ago
Created attachment 251937 [details]
testcase

Loading this testcase kills Firefox (Mac trunk debug) with the message:

mozilla/gfx/cairo/cairo/src/cairo-pen.c:323: failed assertion `i < pen->num_vertices'

Could this be a regression from bug 367273?

Comment 1

11 years ago
(In reply to comment #0)
> Created an attachment (id=251937) [details]
> testcase
> 
> Loading this testcase kills Firefox (Mac trunk debug) with the message:
> 
> mozilla/gfx/cairo/cairo/src/cairo-pen.c:323: failed assertion `i <
> pen->num_vertices'
> 
> Could this be a regression from bug 367273?
> 

Did you really mean this bug number? It's some kind of UI thing.

Comment 2

11 years ago
Regression caused by bug 367031.

Updated

11 years ago
Blocks: 367031
The patch for bug 367031 was backed out. Should we just close this or try and figure out if the crash is something we could encounter on valid code paths?

Comment 4

11 years ago
Perhaps we could add the testcase to bug 367031 with a note to say whatever fix we do should be tested against that.
This bug is in its depends field so I'll be doing that anyway.
I added the test as http://lxr.mozilla.org/seamonkey/source/layout/reftests/svg/bugs/bug367368.xhtml
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.