A comment like <!-- komentarz1 -- komentarz2 --> bad work. For Opera & IE is good.

RESOLVED DUPLICATE of bug 214476

Status

()

Core
HTML: Parser
--
enhancement
RESOLVED DUPLICATE of bug 214476
11 years ago
11 years ago

People

(Reporter: Stanislaw Kupiec, Assigned: mrbkap)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: v.2.0.0.1

In this problem any string like -- | --- | -----... inside a comment extend it. First symbol --> do not close this comment.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Assignee: nobody → mrbkap
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser
Version: unspecified → 1.8 Branch

Comment 1

11 years ago
Is this report saying that comments are weird? I agree! Without a test case though it is hard to say if there is a bug.

----
BTW: I found this, which explains comments --> http://www.howtocreate.co.uk/SGMLComments.html
what good ideas!
Follow best practices (open the declaration with <! and immediately put only one comment opening with -- and closing with --, and avoiding within the comment any hyphens, exclamations or angle brackets, and closing the declaration immediately with >). If you want a second comment, open a new declaration!

Comment 2

11 years ago
It's illegal syntax, see http://www.w3.org/TR/html4/intro/sgmltut.html#h-3.2.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
You need to log in before you can comment on or make changes to this bug.