Tab Preview Should Be Disabled for Current Tab

RESOLVED FIXED in seamonkey1.1final

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: David E. Ross, Assigned: Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com])

Tracking

({fixed-seamonkey1.1.1})

1.8 Branch
seamonkey1.1final
fixed-seamonkey1.1.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

When I select a tab, its page moves in front of the other tabs, becoming the "current tab".  It's annoying to see the preview of that same page -- blocking me from viewing part of the page itself -- merely because I haven't moved my cursor off the tab.

Reproducible: Always

Steps to Reproduce:
1.  Open several tabs.  
2.  Select a tab that is not the current tab.  
Actual Results:  
There is a preview of the tab that duplicates in miniature what is in the current navigator window.  The preview is over the window.  

Expected Results:  
Since I already see the window, I should not see a preview.  

While I can disable tab previews by setting browser.tabs.tooltippreview.enable to False, that disables ALL previews.  This bug report requests disabling the preview only for the current tab.  

Perhaps this should not be an option since I can't think of why anyone would want a tiny preview of what is already visible in full size.

Updated

10 years ago
Assignee: general → nobody
Component: General → Tabbed Browser
OS: Windows XP → All
Product: Mozilla Application Suite → Core
QA Contact: general → tabbed-browser
Version: unspecified → Trunk
Created attachment 252127 [details] [diff] [review]
patch

ajschult provided a convincing argument.
Assignee: nobody → cst
Status: NEW → ASSIGNED
Attachment #252127 - Flags: superreview?(neil)
Attachment #252127 - Flags: review?(neil)
Component: Tabbed Browser → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
Target Milestone: --- → seamonkey1.1final
Version: Trunk → 1.8 Branch

Comment 2

10 years ago
Comment on attachment 252127 [details] [diff] [review]
patch

>+          if (!this.mPrefs.getBoolPref("browser.tabs.tooltippreview.enable")
>+              || tab == this.mCurrentTab) {
Nits:
Check the tab first, it's quicker
|| goes at the end of the line, not the start of the next line
r+sr=me with those fixed.
Attachment #252127 - Flags: superreview?(neil)
Attachment #252127 - Flags: superreview+
Attachment #252127 - Flags: review?(neil)
Attachment #252127 - Flags: review+
Attachment #252127 - Flags: approval-seamonkey1.1.1?
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
a=me for SM1.1.1 (one more needed)

Comment 5

10 years ago
Comment on attachment 252127 [details] [diff] [review]
patch

a=me for 1.1.1
Attachment #252127 - Flags: approval-seamonkey1.1.1? → approval-seamonkey1.1.1+
Keywords: fixed-seamonkey1.1.1

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.