Select inside display: -moz-grid-line gives very large page and can cause crash [@ QBCurve::SubDivide]

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

Assignee

Description

13 years ago
Posted file testcase
See testcase, that page should not have a very large height, but it does in current trunk builds.
This regressed between 2007-01-16 and 2007-01-17:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-01-16+05&maxdate=2007-01-17+09&cvsroot=%2Fcvsroot
I guess a regression from the check-in for bug 333659.

I'll also attach a testcase that crashes when scrolling down because of this.
Assignee

Comment 1

13 years ago
Posted file testcase2
This testcase crashes for me when scrolling down on the page.

Talkback ID: TB28508398W
QBCurve::SubDivide  [mozilla\layout\base\nscssrendering.cpp, line 4067]
QBCurve::SubDivide  [mozilla\layout\base\nscssrendering.cpp, line 4091]
QBCurve::SubDivide  [mozilla\layout\base\nscssrendering.cpp, line 4091]
etc...
This particular case is fixed by the patch for bug 368247; QBCurve isn't used in this case.  However, QBCurve still exists for backgrounds; it'll be going away entirely shortly.  Marking this FIXED, though.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Assignee

Comment 3

12 years ago
Well, I also filed this because the testcase caused such a large height, but seems to be now worksforme also. I guess that might already have been fixed some time ago.

Updated

12 years ago
Flags: in-testsuite?
Crash Signature: [@ QBCurve::SubDivide]

Comment 4

6 years ago
Crash tests:
https://hg.mozilla.org/integration/mozilla-inbound/rev/55f54e848de6
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.