Last Comment Bug 367607 - URL bar autocomplete stops working sometimes
: URL bar autocomplete stops working sometimes
Status: RESOLVED FIXED
: fixed-seamonkey1.0.8, fixed-seamonkey1.1.1
Product: SeaMonkey
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: All All
: -- major (vote)
: ---
Assigned To: Andrew Schultz
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 11:47 PST by Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
Modified: 2008-07-31 01:18 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
getAttribute returns strings (982 bytes, patch)
2007-01-21 08:20 PST, Andrew Schultz
neil: review+
neil: superreview+
Details | Diff | Splinter Review

Description Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-01-20 11:47:36 PST
1. Type bugz in the URL bar.
2. Mouse over "search google for..."
3. Press the up arrow key
4. Press the left arrow key
5. Curse the developers angrily since autocomplete breaks and gives errors in the JS console.

The first symptom after step 4 is that you can no longer get the "search google for..." entry to highlight.  After closing the current dropdown through any method, you'll never get another one.
Comment 1 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-01-20 15:32:18 PST
This seems to open the sidebar on trunk.
Comment 2 neil@parkwaycc.co.uk 2007-01-21 05:00:28 PST
Sorry, but I was unable to reproduce this with either my trunk or branch builds or a the .zip 1.1 release.
Comment 3 Andrew Schultz 2007-01-21 08:20:04 PST
Created attachment 252219 [details] [diff] [review]
getAttribute returns strings
Comment 4 neil@parkwaycc.co.uk 2007-01-21 08:57:36 PST
Whoops, none of the builds I was testing with had any history for bugzilla...
Comment 5 neil@parkwaycc.co.uk 2007-01-21 09:00:58 PST
Comment on attachment 252219 [details] [diff] [review]
getAttribute returns strings

Although I guess a better fix would be to change engineIndex from an attribute into a <field>.
Comment 6 Andrew Schultz 2007-01-21 09:17:02 PST
Comment on attachment 252219 [details] [diff] [review]
getAttribute returns strings

landed on trunk

looking for seamonkey-approval1.1.1?
Comment 7 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-01-21 12:16:45 PST
Comment on attachment 252219 [details] [diff] [review]
getAttribute returns strings

a=me for sm1.1.1
a=me for sm1.0.8
(I don't think you need another approval b/c neil reviewed the patch)
Comment 8 Andrew Schultz 2007-01-21 12:45:39 PST
ok, landed on both branches

Note You need to log in before you can comment on or make changes to this bug.