Closed Bug 367647 Opened 15 years ago Closed 15 years ago

[SessionStore] multiple http auth dialogs from the same site during restoration

Categories

(Firefox :: Session Restore, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: fabian, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)

When firefox restores tab at starting (after a crash, or because of preferences) I often have 10 or 20 http-login pages open.
Then I often get several loginboxes to log into the server.
This is very annoying.

It would be good if the entry in one form would propagate to the others. Or that just one form is showed when several tabs need the same information.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Whiteboard: DUPEME
You're talking about http auth dialogs, right?
Component: General → Startup and Profile System
QA Contact: general → startup
Summary: when the browser restores tabs after starting you have to fill in login information several times → [SessionStore] when the browser restores tabs after starting you have to fill in login information several times
For comparison, here's a page that uses http auth and causes Firefox to show an http auth dialog: http://www.squarefree.com/stats/
Yes.
Summary: [SessionStore] when the browser restores tabs after starting you have to fill in login information several times → [SessionStore] multiple http auth dialogs from the same site during restoration
Component: Startup and Profile System → Session Restore
QA Contact: startup → session.restore
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 348997
You need to log in before you can comment on or make changes to this bug.