make error logging in updater.cpp more verbose (especially on error)

RESOLVED DUPLICATE of bug 316890

Status

()

RESOLVED DUPLICATE of bug 316890
12 years ago
10 years ago

People

(Reporter: moco, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

make error logging in updater.cpp more verbose on error

spun off from bug #367669 and bug #367084
I've got a patch in bug #367084 to make things a little better.

if the file is in use by another process (like chrome/browser.manifest from shaver, in bug #367669)

we'll get:

remove failed: 13,-1 (chrome/browser.manifest)

note, if the file is just read only (see bug #367084), you would not see this error as the patch will attempt to change the perms.

but if that fails, you'd get:

remove failed: 13,-1 (chrome/browser.manifest)

so after my patch, there still won't be a way to determine the difference between those failures.
Status: NEW → ASSIGNED
sorry for the bug spam, re-assigning bugs back to default owner if I'm not working actively on them.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316890
You need to log in before you can comment on or make changes to this bug.