selected message not scrolled into view after clearing quicksearch

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Andrew Schultz, Assigned: Karsten Düsterloh)

Tracking

({fixed-seamonkey1.1.2})

Trunk
fixed-seamonkey1.1.2
Bug Flags:
blocking-seamonkey1.1.1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

783 bytes, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
As mentioned on mozilla.support.seamonkey, if you
1. enter a term into the quicksearch box
2. select a message
3. hit "clear"

the thread pane seems to always scroll to the bottom.  The selected message remains selected, but is no longer visible.  This regressed between 2006-12-19-08-trunk and 2006-12-20-08-trunk and is also on the branch, so this is from bug 363831.

Comment 1

12 years ago
Same thing happen when I read newsgroups using "Space-Bar", after going to next group with unread Messages, marked Message in Thread-Pane was not visible in the Pane(Window). Think this was the same Bug, if not I would file another. 
(Assignee)

Comment 2

12 years ago
Actually, I suspect that both your and Andrew's problem is covered by bug 365049.

Comment 3

12 years ago
Jepp, sounds good, thanks for the hint. Dupe this one to Bug 365049?
(Assignee)

Comment 4

12 years ago
I'll do that when I know for sure that it's the same problem.
(Reporter)

Updated

12 years ago
Flags: blocking-seamonkey1.1.1?

Comment 5

11 years ago
I don't think we'll hold off a release for this, it's just a small visual glitch - though it would be good to have it fixed, of course.
Flags: blocking-seamonkey1.1.1? → blocking-seamonkey1.1.1-
(Reporter)

Updated

11 years ago
Duplicate of this bug: 371847
Duplicate of this bug: 376161
Is there anything I can do to help this along?  This is a serious time-waster for me; enough so that it's making me consider going back to an older nightly...
(Assignee)

Comment 9

11 years ago
I still see this under Windows, so it's not fixed by bug 365049. :|
Investigating.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 10

11 years ago
Created attachment 260281 [details] [diff] [review]
readd missing condition

Sorry for the delay.
Attachment #260281 - Flags: superreview?(neil)
Attachment #260281 - Flags: review?(neil)

Updated

11 years ago
Attachment #260281 - Flags: superreview?(neil)
Attachment #260281 - Flags: superreview+
Attachment #260281 - Flags: review?(neil)
Attachment #260281 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #260281 - Flags: approval-seamonkey1.1.2?

Comment 11

11 years ago
Comment on attachment 260281 [details] [diff] [review]
readd missing condition

a=me for 1.1.2 (I think that's trivial enough to not need a second approval, esp. as it's coming from the module owner)
Attachment #260281 - Flags: approval-seamonkey1.1.2? → approval-seamonkey1.1.2+
(Assignee)

Comment 12

11 years ago
Landed on trunk and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: regression → fixed-seamonkey1.1.2
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.