Animated GIFs seem to hog the CPU

VERIFIED DUPLICATE of bug 41268

Status

()

Core
ImageLib
P3
normal
VERIFIED DUPLICATE of bug 41268
18 years ago
18 years ago

People

(Reporter: Peter Trudelle, Assigned: pnunn)

Tracking

({perf})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+], URL)

(Reporter)

Description

18 years ago
I was parked on Tinderbox, watching the trees burn as I am wont to do of a
Friday, when I noticed that my CPU was nearly pegged.  I launched gTop,and saw
that mozilla was sucking up 80% of the available CPU cycles (from 2 PIII 500s!).
 I switched back to the pre=checkin page, and saw the usage drop immediately to
nearly 0.  I switched back to Tinderbox, and it went back up to 80%.  Then I
scrolled so that the flames (animated gifs) were no longer visible.  The CPU
utilization went down to 10-14%.  Scrolling them back into view brings the CPU
back to 80%. It sure seems like they are somehow using up about 800Mhz of CPU
bandwidth.
(Assignee)

Comment 1

18 years ago
I checked with some linux folk who confirm that animations
really hit resources hard. I've talked to Pav, and we are 
going to work out some changes so gtk doesn't have to convert
data as much as it does now. I will fold this into the new
imglib design considerations.
-P
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 2

18 years ago
umm there may be a leak also, somewhere. I left moz open with a animated gif 9k
big, as an experiment. A small webpage, no scrollbars. Disconnected modem, got
back 10 hours later, and it was still animating. But i was down 4.5 MB on free
RAM. This was about 10 days ago.
(Assignee)

Comment 3

18 years ago
This problem appears to be table related.
Try:

jazz/users/pnunn/publish/tablebkgd1.html

-p
(Assignee)

Updated

18 years ago
Keywords: nsbeta3

Updated

18 years ago
Whiteboard: [nsbeta3-]

Comment 4

18 years ago
Pam we should evaluate this with respect to the new imglib bugs filed. Can 
someone confirm that this still is a CPU hogging problem? Renominate if we 
really hog it :)
(Reporter)

Updated

18 years ago
Whiteboard: [nsbeta3-]
(Reporter)

Comment 5

18 years ago
Tinderbox doesn't seem to have the flame animations anymore, but the page Pam
cites uses 80-90% of one of my CPUs while it is animating.  I think this is
worse on Windows, where the default first page for a new profile pegs my poor
Win98 box.

Comment 6

18 years ago
triage team:
seems to hit perf and memory footprint badly, therefore +
Keywords: perf
QA Contact: elig → tever
Whiteboard: [nsbeta3+]

Comment 7

18 years ago
*** Bug 38033 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

18 years ago
This bug has been (and is being) addressed in other bugs.
The last bug scheduled to help animation performance is
#41268. 
I'm marking this bug a duplicate of #41268.

*** This bug has been marked as a duplicate of 41268 ***

Comment 9

18 years ago
Verified dupe of bug 41268: "imglib should cache chrome animations"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.