Closed Bug 367877 Opened 14 years ago Closed 14 years ago

Can't download update for plugins on FireFox startup, when proxy server with password specified.

Categories

(Toolkit :: Add-ons Manager, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 312473

People

(Reporter: takemesite, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I have an proxy served internet connection. Proxy requires login and password.
When i'am udating plugins from plugins manager in browser window - all ok.
But when plugins update is running automaticly during firefox startup downloading of the plugin file fails.

Reproducible: Always

Steps to Reproduce:
0. Configure FireFox to use proxy requiring autentification. Mine proxy is on port 8080.
1. Start FireFox, with not lastest plugin.
2. Plugin update window rises and tells me about aviable updates.
3. Click "Download update".
4. Failure window rises.
Actual Results:  
After clicking OK in failure window, browser continues to load and working perfectly, plugins should be updated, weren't updated. Updating plugins manually works perfectly, like all other.

Expected Results:  
I think proxy autorisation window sould occur after "Download update" button was clicked.

That situation was seen when updating FlashGot plugin to version 0.5.97.03 on Russian language version of FireFox. Think windows and button names may be little different from described here, but main sense should be clear.
Version: unspecified → 2.0 Branch
I think you mean Add-ons (or extensions) rather than Plugins (Java, Flash etc). Either way this is a dupe ...
Component: Software Update → Extension/Theme Manager
QA Contact: software.update → extension.manager
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312473
Yes, I ment Add-ons. Have read bug 312473, think it's the same.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.