Closed Bug 367884 Opened 16 years ago Closed 15 years ago

Khmer Unicode font substitution fails on minefield

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nirvn.asia, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070120 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070120 Minefield/3.0a2pre

Going on www.licadho.org/media/home.php using a trunk build of firefox under linux (ubuntu edgy/feisty) will show blank characters while trying to display Khmer Unicode in between the ( ).

I will do further tests but it seems to be a font selection/substitution issue: if I style the <span> with a Khmer Unicode font, characters will show properly.

This was working flawlessly under firefox 2.0 using the same computer. Probably a cairo/thebes related problem...

Reproducible: Always
hrm, should have mentioned this before: some Khmer fonts can be downloaded @ khmeros.info
Component: Layout: Fonts and Text → GFX: Thebes
QA Contact: layout.fonts-and-text → thebes
Attached file test case
A simple test case with two <p> elements.

1st <p> will not display Khmer Unicode 
2nd <p> will display Khmer Unicode after setting a Khmer Unicode font

It seems font substitution is broken... Interestingly, if you go on 'view source', the Unicode text will appear without any problem.

Will attach a screenshot later.
Attached image screenshot of testcase
testcase using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070205 Minefield/3.0a2pre

without CSS font-family statement, Unicode gets screwed up...
Status: UNCONFIRMED → NEW
Ever confirmed: true
this works correctly for me.

Can you run with NSPR_LOG_MODULEs=winfonts:5 NSPR_LOG_FILE=c:\foo.txt and post the output?
should look something like:
0[ba3390]: trying: Times New Roman
0[ba3390]: Trying to find fonts for: x-khmr (KHMER)
0[ba3390]: trying: Khmer OS
0[ba3390]: Khmer OS - worked
0[ba3390]: trying: Khmer OS System
0[ba3390]: Khmer OS System - worked
stuart, on Windows, font substitution works ok; it's on Linux that the process fails to select appropriate font & text vanishes. I'll try to run test with these variables on my linux box tonight...



ah, ok. sorry I confused myself!
hrm, on my linux box, tried NSPR_LOG_MODULES=all:5 (not aware of *nix equivalent of winfonts name). 

Firefox doesn't output any fonts substitution message in foo.txt... I'm lost.
To get a Khmer Unicode font (not coming by default in any OS)

http://prdownloads.sourceforge.net/khmer/KhmerOSsys.ttf?download
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Flags: blocking1.9+ → blocking1.9-
Whiteboard: [wanted-1.9]
Depends on: 362682
Both lines in the testcase are identical in a current trunk build
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
You need to log in before you can comment on or make changes to this bug.