Error while adding float numbers

RESOLVED DUPLICATE of bug 20140

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 20140
12 years ago
12 years ago

People

(Reporter: Xavier OTTOLINI, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8

An error occures when I try to add float numbers with Javascript. The result is sometimes false.


Reproducible: Always

Steps to Reproduce:
1. Create a page with the following script :
<script language="javascript" type="text/javascript">//<![CDATA[

	var e = 4.290 + 75.030;
	alert(e);
</script>
2. Open the page with Firefox
3. The result is 79.32000000000001.
Actual Results:  
The result is 79.32000000000001

Expected Results:  
The result should be 79.32
(Reporter)

Comment 1

12 years ago
Created attachment 252891 [details]
HTML file to test the error

Comment 2

12 years ago
Duplicate of bug 20140.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 20140
You need to log in before you can comment on or make changes to this bug.