Closed Bug 368293 Opened 14 years ago Closed 13 years ago

SeaMonkey crash when open "Message Filters" after navigating with "space" in Newsgroups

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: tobias, Unassigned)

References

Details

(Keywords: crash, regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070125 Mnenhy/0.7.4.10005 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070125 Mnenhy/0.7.4.10005 SeaMonkey/1.5a

SeaMonkey (Windows) crashes since Build 2006120808 reproduceable when I read Messages in Newsgroups, navigating from one Message to the next with space and then open "Message Filters..." from Tools-Menu. 

Note, it was not too easy to reproduce the crash, when I open an Newsgroup and mark a Message in Thread-Pane, SM won't crash until I have changed from the frist marked to another message and open "Message Filters". Also I haven't defined any Filters before in this Account. 

Reproducible: Always

Steps to Reproduce:
1. Go to News-Account, open a Group and mark a Message in Thread-Pane
2. Move with "Space" almost to next unread message (hmm, works also when mark another Message with Mouse, and sometimes it was nessecary to go on and read more than two Messages in Group)
3. Open "Message Filters" via Tools-Menu
Actual Results:  
SeaMonkey crash. 

Expected Results:  
Open Message Filters Dialog, no crash.

Can reproduce the crash also with Mnenhy deinstalled. Got some TB-incidents: TB28721616H, TB28720955Q, TB28719181G but the stack was not really helpfull.
Regression Window:
Build 2006120708 works fine
Build 2006120808 crashes. 

Bonsai:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-12-07+08%3A00%3A00&maxdate=2006-12-08+08%3A45%3A00&cvsroot=%2Fcvsroot

Probably this was a Fallout from Bug 361708, but I don't know really. CC'ing Ian Neal and Karsten Düsterloh, hope thats o.k. 
Keywords: crash, regression
From Bonsai and looking at the talkbacks I would suggest it is the fix to bug 300030 causing the issue. Maybe worth cc'ing dbaron or marking a dependency with the reflow bug.
Starting with Build 2007012809 I can't reproduce this crash anymore. 

Seems to be fixed from a checkin between 2007012608 and 2007012808. Build 2007012708 is crashing at startup, so I can't cut down the Checkin-Window.

If someone could test this with an current Nightly and get no crash when open Message-Filters, I would close this Bug as resolved=worksforme then. 
Well, I can't reproduce this crash anymore with current Nightlies. Close this as resolved=worksforme to cut down number of open Bugs. 
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.