Closed Bug 368299 Opened 13 years ago Closed 7 years ago

SeaMonkey start up preference makes mail client start multiple times

Categories

(SeaMonkey :: Preferences, defect, minor)

x86
Windows 2000
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: lode, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

When the preferences are such that I want to start up the Navigator
and the Mail client. It starts them both up correctly the first time.
But when keeping the mail client open and closing the navigator, a bug happens.
When starting seamonkey using the shortcut it opens a navigator and again a mail client. Mozilla 1.17 did check for this and only opened the navigator such that only one mail client was open.

Reproducible: Always

Steps to Reproduce:
1. Check Navigator and Mail client in the preference window for start up.
2. Open Seamonkey through seamonkey.exe
3. Close the Navigator
4. Redo step 2. open seamonkey.exe

Actual Results:  
The mail client will open again.

Expected Results:  
The mail client is still open and should not open again. (see mozilla behavior)
I see this also in the trunk.

Possibly a side-effect of the fix for bug 58523.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Can you reproduce with SeaMonkey v1.1.9 ?
Can you reproduce with SeaMonkey v2.0a1pre ?
Assignee: prefs → nobody
QA Contact: prefs
Version: unspecified → Trunk
(In reply to comment #2)
> Can you reproduce with SeaMonkey v1.1.9 ?

Yes, same problem.

> Can you reproduce with SeaMonkey v2.0a1pre ?

Did not try this one.

(In reply to comment #3)
> (In reply to comment #2)
> > Can you reproduce with SeaMonkey v1.1.9 ?
> 
> Yes, same problem.
> 
> > Can you reproduce with SeaMonkey v2.0a1pre ?
> 
> Did not try this one.

Tested the bug with SeaMonkey v2.0b2 and the bug seems to be gone, the only thing that sometimes happens now is that the start page is not loaded when I open a new window and I get a blank page.

I am not able to reproduce the behavior, if I find some pattern of how or when it occurs, I will reply on this comment.
No reports in four years so I guess I can close this bug now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
FYI. Definitely Resolved.

I haven't seen the issue re-arise in the last four years.
The issue which I'm mentioning with regard to the start page also doesn't occur anymore.
You need to log in before you can comment on or make changes to this bug.