sometimes sessionrestore opens empty window

RESOLVED DUPLICATE of bug 395478

Status

()

RESOLVED DUPLICATE of bug 395478
12 years ago
11 years ago

People

(Reporter: romgohan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I had three browser windows with tabs open, sessionrestore correctly restored two windows and the third one was completly empty, it had no tabs, nothing only empty white space. After exit and start again two windows are restored correctly but in the third window only empty tabs are created.

Reproducible: Sometimes




 Maybe you could create some backup copies of sessionstore.js similar to bookmarks backup? It worked when I replaced the corrupted sessionstore.js with a backup one I created.

Comment 1

12 years ago
Created attachment 264773 [details] [diff] [review]
temporarily cache data for to-be-restored windows

Together with the proposed patch to bug 367605, this should fix many of the most common dataloss situations related to SessionStore.
Attachment #264773 - Flags: review?(dietrich)

Updated

12 years ago
Blocks: 356050
(Reporter)

Comment 2

12 years ago
Just wanted to say, that nothing changed in 2.0.0.3, it never happened when I had only two pages, but when I created third page with about 10 tabs, the session restore did not work, as described in the bug report.
(In reply to comment #1)
> Created an attachment (id=264773) [details]
> temporarily cache data for to-be-restored windows
> 
> Together with the proposed patch to bug 367605, this should fix many of the
> most common dataloss situations related to SessionStore.
> 

Are there clear steps-to-reproduce for this bug?

How exactly does this patch address restoration from premature crashes, or the specific scenario described in this bug?

Comment 4

12 years ago
Created attachment 269091 [details] [diff] [review]
temporarily cache data for to-be-restored windows

(In reply to comment #3)
> Are there clear steps-to-reproduce for this bug?

1. Open at least a dozen windows with non-blank content.
2. Set Firefox to resume the session at startup
3. Quit and reopen Firefox
4. Quit again ASAP

Actual result:
Many if not most windows contain only blank tabs.

Expected result:
Everything is restored after point 4 as after point 3.

> How exactly does this patch address restoration from premature crashes

Actually it doesn't. Further tests showed that the issue appears at a slightly later stage: while a window waits for all tabs to become available it doesn't store tab data anywhere. If Firefox is quit while there are still some timeouts in restoreHistoryPrecursor pending, that data is lost.

Temporarily saving tab data in a separate variable which could be used at the next startup now fixes the issue for me.
Assignee: nobody → zeniko
Attachment #264773 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #269091 - Flags: review?(dietrich)
Attachment #264773 - Flags: review?(dietrich)
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
  Situation described in comment #4 is not the same as the bug report, where one window opened empty (literally empty, only white space, no tabs, no menu, no toolbar, nothing). 
   I was not able to reproduce the bug today with firefox 2.0.0.4, so maybe it was fixed in that release? anyway I cannot confirm its existence anymore.
(Reporter)

Comment 6

12 years ago
I have to withdraw my previous comment, I started using 3 windows again and the bug immediately returned, often one window is completely empty.

Comment 7

11 years ago
Comment on attachment 269091 [details] [diff] [review]
temporarily cache data for to-be-restored windows

Not a patch to this bug (see comment #5).
Attachment #269091 - Attachment is obsolete: true
Attachment #269091 - Flags: review?(dietrich)

Updated

11 years ago
Assignee: zeniko → nobody
Status: ASSIGNED → NEW

Updated

11 years ago
No longer blocks: 356050

Comment 8

11 years ago
Filed bug 395488 for the issue from comment #4.

Duping this bug to one without interference from a different issue.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395478
You need to log in before you can comment on or make changes to this bug.