Move copyrightText from aboutDialog.dtd to anywhere in branding directory

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: torisugari, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
copyrightText contains branding sensitive things. And
it would painful for 3rd ditributors to overwrite
the whole file: aboutDialog.dtd, because of l10n restrictions.

Comment 1

11 years ago
Confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Taking over...
Assignee: nobody → ehsan.akhgari
Summary: Move copyrightText from aboutDiarlog.dtd to anywhere in branding directory → Move copyrightText from aboutDialog.dtd to anywhere in branding directory

Comment 3

11 years ago
Created attachment 273010 [details] [diff] [review]
Correct the branding information for the about dialog

This patch attempts to correct the copyright text in the about dialog for each product (firefox, nightly, unofficial).
Attachment #273010 - Flags: review?(mano)

Updated

11 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Created an attachment (id=273010)

If a rebranding developer try to create a product based on /mozilla/browser
(Firefox), who is the copyright owner, Mozilla or the rebrander? Mozilla
is definitely the owner, but the developer have to append their copyrighted
artworks so, he/she also has the copyright of the re-branded product.

The vendor name is not always equal to the copyright owner. We should provide
for rebranding developers a way to add their own copyright terms, instead
of overwriting MoFo's.

Comment 5

11 years ago
Created attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

(In reply to comment #4)
> If a rebranding developer try to create a product based on /mozilla/browser
> (Firefox), who is the copyright owner, Mozilla or the rebrander? Mozilla
> is definitely the owner, but the developer have to append their copyrighted
> artworks so, he/she also has the copyright of the re-branded product.
> 
> The vendor name is not always equal to the copyright owner. We should provide
> for rebranding developers a way to add their own copyright terms, instead
> of overwriting MoFo's.
> 

The new patch adds a rebrander specific copyright text which, if available, will appear in addition to MoFo's copyright text.  Does it correctly address the concerns of this bug?
Attachment #273010 - Attachment is obsolete: true
Attachment #273091 - Flags: review?(mano)
Attachment #273010 - Flags: review?(mano)
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

needs review from the Mikes.
Attachment #273091 - Flags: review?(mano)

Comment 7

11 years ago
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

Requesting review from mconnor...
Attachment #273091 - Flags: review?(mconnor)
(Reporter)

Comment 8

11 years ago
1. Why JavaScript? JavaScript is a run-time functionality. On the other hand,
copyright text is fixed on build-time.

2. For what vendorFullName is?

Comment 9

11 years ago
(In reply to comment #8)
> 1. Why JavaScript? JavaScript is a run-time functionality. On the other hand,
> copyright text is fixed on build-time.

The JavaScript code just hides the rebrander text box in builds where the rebreander copyright text is not provided.  This just helps to maintain the look and feel of the about dialog in the official, unofficial and nightly builds.

> 2. For what vendorFullName is?

vendorFullName indicates the full name of the vendor which holds trademarks over the logos used in the branding.  For example, it's "Mozilla Foundation" for the official braning, while vendorShortName is "Mozilla" on those builds.

The logic is similar to the brandShortName and brandFullName entities.
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> The JavaScript code just hides the rebrander text box in builds where the
> rebreander copyright text is not provided.  This just helps to maintain the
> look and feel of the about dialog in the official, unofficial and nightly
> builds.

Well, I'm not asking what your script is doing. Why you have to use
JavaScript? When you build your product, you know whether it needs
extra copyrights text or not. Why not Makefile?

> vendorFullName indicates the full name of the vendor which holds trademarks
> over the logos used in the branding.  For example, it's "Mozilla Foundation"
> for the official braning, while vendorShortName is "Mozilla" on those builds.

My question was why you need to split vendorFullName from copyrightText.
vendorFullName doesn't seem to have anything to do with this bug, does it?

> The logic is similar to the brandShortName and brandFullName entities.

Note that brandShortName and brandFullName are referenced from a lot of
UI files. How many times vendorFullName will be?

Comment 11

11 years ago
(In reply to comment #10)
> Well, I'm not asking what your script is doing. Why you have to use
> JavaScript? When you build your product, you know whether it needs
> extra copyrights text or not. Why not Makefile?

Well, I don't know how to do that in a Makefile.  Any ideas?

> My question was why you need to split vendorFullName from copyrightText.
> vendorFullName doesn't seem to have anything to do with this bug, does it?

If that's an issue, I can leave vendorFullName in the copyrightText.  Perhaps we should get a review on the patch first?

> Note that brandShortName and brandFullName are referenced from a lot of
> UI files. How many times vendorFullName will be?

Currently, only from copyrightText.  But I fail to see the harm in that separation...

Comment 12

11 years ago
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

This needs some acceleration because the l10n freeze is near.
Attachment #273091 - Flags: review?(mconnor) → review?(mano)
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

I'm still not the right reviewer for this, sorry.
Attachment #273091 - Flags: review?(mano)

Comment 14

11 years ago
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

(In reply to comment #13)
> (From update of attachment 273091 [details] [diff] [review])
> I'm still not the right reviewer for this, sorry.

Oops! :"> (Banging myself on the forehead)
Attachment #273091 - Flags: review?(mconnor)
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

I'm pretty sure this is actually wrong, the trademark text does not apply to Minefield/Gran Paradiso, etc...

not sure what the right answer is here, maybe have a whole copyright blurb that's empty for unbranded versions?  maybe ask Gerv, he has more cycles to think about copyright notices than I do at this moment...
Attachment #273091 - Flags: review?(mconnor) → review-

Comment 16

11 years ago
Gerv: please see comment 15.
Comment on attachment 273091 [details] [diff] [review]
Correct the branding information for the about dialog providing a rebrander copyright text

 >+<!ENTITY copyrightText          "&#169;1998-2007 Contributors. All Rights Reserved. &brandShortName; and the 
>+                                 &brandShortName; logos are trademarks of the &vendorFullName;.  All rights 
>                                  reserved. Some trademark rights used under license from The 
>                                  Charlton Company.">

This doesn't work, because the Charlton Company stuff is Firefox-specific. Although that text needs to move to about:licence anyway.

I do see the problem you are trying to solve, though. If FooCorp release FooBrowser, we want to maintain the fact that the codebase is copyright by contributors to the Mozilla project, but we also want to allow them to say that their changes are copyright FooCorp. Of course, they could do that just by replacing the last half of the copyrightText, couldn't they?

Gerv

Comment 18

11 years ago
Updating to reality...
Assignee: ehsan.akhgari → nobody
Status: ASSIGNED → NEW
Bug 536336 removed the copyright strings, so this is no longer valid...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.