Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Charles Emley, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

({fixed1.8.1.2})

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070128 Camino/1.1a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070128 Camino/1.1a2+

Click the "Today's Video" link on the site's menu (upper right) and it opens a window to display news videos using Adobe Flash and Brightcove.  Works fine in Safari and Firefox.  In Camino, the window opens then nothing loads, just a green painted screen.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.marketwatch.com/
2. Click "Today's Video"
3.
Actual Results:  
New window opens, nothing else happens.

Expected Results:  
Flash (Brightcove) player should load and video should begin to play.

Comment 1

12 years ago
It works if ad blocking is turned off. The issue is that the movie is an <embed> with a src of the form:
http://admin.brightcove.com/[...]&adServerURL=http%3A%2F%2Fad.doubleclick.net%2Fpfadx%2Fvideo.marketwatch.com%2Fdefault[...]
so it's tripping the doubleclick embed rule.

Confirming, but I'm not sure how fixable this really is.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Plug-ins → Annoyance Blocking
QA Contact: plugins → annoyance.blocking
I'm willing to give

embed[type="application/x-shockwave-flash"][src^="http://ad."][src*="doubleclick.net"],

a try.

The issue is that doubleclick has servers like ad.eu.doubleclick.net and so forth.  So long as there aren't legit servers out there that start with "ad." and serve content with URLs like the marketwatch video, we'll be OK for legit content.

We'll have to keep our eyes open for doubleclick regressions, though.
Status: NEW → ASSIGNED
Depends on: 362330
Fixed by bug 362330.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
Assignee: nobody → alqahira
You need to log in before you can comment on or make changes to this bug.