both bookmark & its backup detected as truncated by scandisk if firefox is running and system power fails.

RESOLVED DUPLICATE of bug 193749

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 193749
12 years ago
12 years ago

People

(Reporter: paul, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

This is a major problem due to which i lost all my Bookmarks, and not able to retrieve it even being a good knowledge of recovery.

PROBLEM IS :
While browsing in Firefox, if the system power is switched off then i've found that in most of running cases both Bookmark.htm and bookmark.bak is reported as truncated or corrupted by windows XP initial SCAN DISK.
It also happens with the history and session restore feature of firefox.

There is no use of disabling the windows XP disk cache, as it would affect other hundreds of programs.

Reproducible: Always

Steps to Reproduce:
1. open and run the firefox 2.0.0.1
2. now add any bookmark and open more than one or single page tab.
3. Now make sure some site is loading on tabs
4. power off the system, or if the system crashes due to any other software.
5. let windows XP run the scandisk, it will find and truncated :
session.js, bookmark.htm, bookmark.bak and any other firefox cache file opened during the process.

Actual Results:  
1.Run Firefox 2.0.0.1
2.make sure some sites are loading
3. switch off the pc, or if system crash due to unexpected reason
4. let XP run scandisk, it 'll truncate firefox files which were open during the work.

Expected Results:  
Scandisk truncate the firefox files, session.js, bookmark.htm, bookmark.bak 




It should be no mean of Firefox, if restore feature is not enabled and bookmark gets deleted automatically by WINDOWS XP SCANDISK.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
Dupe of Bug 193749?
yes, it is
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 193749
You need to log in before you can comment on or make changes to this bug.