Closed Bug 369231 Opened 16 years ago Closed 16 years ago

Resume occasionally reports unfinished download as complete.

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 237623

People

(Reporter: darksaiyan, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

After pausing a download, waiting for some time, then resuming the download, the download is reported as 'Complete' but is actually unfinished.

This has occurred on several separate occasions, though am having difficulty reproducing the bug.

Reproducible: Sometimes

Steps to Reproduce:
1. Clicked link to download (in last case it was AVG Free - http://free.grisoft.com/softw/70free/setup/avg75free_432a904.exe)
2. Clicked Pause the to pause the download
3. Waited for some time (actions varied here, may have contributed)
4. Clicked Resume to resume the download
5. Download immediately reported as 'Complete'
6. Ran the avg exe
7. File was declared corrupt/unfinished
Actual Results:  
File was reported as Complete, using the file got corrupt/unfinished errors.

Expected Results:  
Download was expected to resume, with stats (time, progress) to completion.
Probably a dupe of bug 237623.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Different circumstances, but likely the same cause.  Though I do not have the file being overwritten as in bug 237623 - the file is duplicated on consecutive attempts.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.