Floated list item creates doubled margin on other list items

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Chris Ovenden, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070205 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070205 Minefield/3.0a2pre

I have a list with four items. The first is floated left with a width of 250px. The others have a left margin of 270px, but those which appear next to the floated item have a left margin which is approximately double what it should be. Items appearing below the float have the correct margin. This displays normally in IE7 and Opera 9.0.2, and also in Firefox if the UL and LI elements are replaced by DIVs.

Reproducible: Always

Steps to Reproduce:
See attachment



Discovered in FF 2.0; still present in 3.0a2
(Reporter)

Comment 1

12 years ago
Created attachment 254040 [details]
Test case

This HTML demonstrates the bug
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk

Comment 2

10 years ago
While buggy in Firefox 2, I can't reproduce the problem in release builds of Firefox 3 or on trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 3

10 years ago
Created attachment 358621 [details] [diff] [review]
two reftests

One for left and one for right floaters.
Attachment #358621 - Flags: superreview?(dbaron)
Attachment #358621 - Flags: review?(dbaron)
This was fixed by bug 413840.
Depends on: 413840
Comment on attachment 358621 [details] [diff] [review]
two reftests

r+sr=dbaron, although I expect the tests added for bug 413840 covered this case
Attachment #358621 - Flags: superreview?(dbaron)
Attachment #358621 - Flags: superreview+
Attachment #358621 - Flags: review?(dbaron)
Attachment #358621 - Flags: review+

Updated

10 years ago
Flags: in-testsuite?
Keywords: checkin-needed

Comment 6

10 years ago
http://hg.mozilla.org/mozilla-central/rev/7417bc6b3de5
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.