"Clear Private Data" doesn't clear javascript errors.

RESOLVED DUPLICATE of bug 322169

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 322169
11 years ago
11 years ago

People

(Reporter: Craig, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Tools --> Clear Private Data doesn't clear error messages from the JavaScript Console.  Since many/most web sites have JavaScript and/or CSS errors, you can easily tell what web sites have been visited recently by opening the JavaScript console, even after clearing all private data.

Reproducible: Always

Steps to Reproduce:
1. Visit any site that has a javascript error, e.g. www.microsoft.com
2. Click "Home"
3. Select Tools->Clear Private Data
4. Select Tools->Javascript Console
Actual Results:  
The CSS errors from www.microsoft.com are displayed, showing that the site was visited.

Expected Results:  
It should have cleared the JavaScript console.
Please don't report bugs on older releases without testing the newest release and also search before you file a bug report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322169
You need to log in before you can comment on or make changes to this bug.