Closed Bug 369576 Opened 14 years ago Closed 13 years ago

Caret is invisible when at end of scrolled textbox

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: access, regression, testcase)

Attachments

(1 file)

Attached file testcase
When a single-line textbox has enough content to scroll, and the caret is at the end, the caret is invisible (it should be visible and blinking).  This affects both <input> in web pages and the address bar.

This happens with:
* cmd+right (go to end of line)
* pressing the right arrow key until the end
* typing enough text into an empty textbox to make it start scrolling

Regressed between 2006-12-07 and 2006-12-08 trunk builds.  Regression from bug 344228 or bug 300030?
Flags: blocking1.9?
Moving to Core/Layout (Editor code is not in charge of painting the caret).
Component: Editor → Layout
QA Contact: layout
Sounds like a dupe of bug 335560 or bug 130530 (they may be dupes of each other as well).

Anyway, see discussions in those bugs.
Duplicate of this bug: 370169
Flags: blocking1.9? → blocking1.9+
OS: Mac OS X → All
Hardware: PC → All
I don't know if this is related, but when I go to http://www.zoekopdekaart.nl/ and increase the text size, the cursor appears outside the input box. This is also a regression from bug 300030.
Depends on: 130530, 335560
I can't reproduce this in [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090416 Minefield/3.0a8pre]. I can still reproduce it in [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6] in the address bar though. Was it perhaps fixed when bug 335560 was fixed? Can anyone else reproduce this in Minefield?
I don't see it.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007090419 Minefield/3.0a8pre
I'm going to mark this FIXED, assuming the checkin for bug 335560 fixed it.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
I can't reproduce this bug any more.
You need to log in before you can comment on or make changes to this bug.