Should the cycle collector ignore its scan delay at shutdown?

RESOLVED DUPLICATE of bug 366578

Status

()

defect
RESOLVED DUPLICATE of bug 366578
12 years ago
12 years ago

People

(Reporter: peterv, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
The cycle collector has a scan delay (currently set at 10 collection attempts) to avoid scanning freshly suspected pointers, so that we know their refcount has somewhat stabilized. I wonder if we should ignore that delay on shutdown, wouldn't it be better to try to collect all potential cycles then?
(Reporter)

Updated

12 years ago
Summary: Should the cycle collector ignore it's scan delay at shutdown? → Should the cycle collector ignore its scan delay at shutdown?
I thought the patch to scan at shutdown did do that.  If it doesn't, we should.
(Reporter)

Comment 2

12 years ago
Grrrr, mxr's version of nsCycleCollector.cpp is out-of-date.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366578
You need to log in before you can comment on or make changes to this bug.