Last Comment Bug 369710 - No talking alerts
: No talking alerts
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- enhancement (vote)
: mozilla12
Assigned To: Hubert Figuiere [:hub]
:
Mentors:
Depends on:
Blocks: osxa11y
  Show dependency treegraph
 
Reported: 2007-02-08 00:47 PST by Doug Grinbergs
Modified: 2012-01-30 09:58 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Alerts are now usable with VoiceOver. r= (2.48 KB, patch)
2012-01-24 11:24 PST, Hubert Figuiere [:hub]
no flags Details | Diff | Splinter Review
Alerts are now usable with VoiceOver. r= (2.48 KB, patch)
2012-01-24 11:34 PST, Hubert Figuiere [:hub]
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description Doug Grinbergs 2007-02-08 00:47:11 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US) AppleWebKit/125.4 (KHTML, like Gecko, Safari) OmniWeb/v563.66
Build Identifier: 1.5.0.9, 2.0.0.1

Alert text not spoken

Reproducible: Always

Steps to Reproduce:
Set-up: System Prefs/Speech/Text to Speech: talking alerts enabled, reasonably short delay

A scenario to display an alert; expecting talking alert

1 Launch app
2 New window
3 Open webpage
4 New tab
5 Open webpage
6 Click window close button
Actual Results:  
"Confirm close" sheet appears, but text not spoken

Expected Results:  
First line of alert text spoken. Can use Script Editor for reference (new, make change, close)

Observed:
2.0.0.1, 10.4.9 8P2122, iMac Core Duo/1.83G
1.5.0.9, 10.4.6 8I127, iBook G3/900
Comment 1 Frankie 2007-11-27 13:08:37 PST
Confirming lack of text to speech in alert dialogs.
Comment 2 David Bolter [:davidb] 2009-06-16 11:48:07 PDT
Mass un-assigning bugs assigned to Aaron.
Comment 3 alexander :surkov 2011-08-29 02:48:04 PDT
Do we have component for text-to-speech support since it appears right people aren't cc'ed here?
Comment 4 Marco Zehe (:MarcoZ) 2011-11-01 06:24:28 PDT
This is a platform integration bug rather than accessibility. It is about supporting the default speech alerting system in Mac OS X. Setting to Widget: Cocoa for now in hopes this can be triaged to platform integration.
Comment 5 Hubert Figuiere [:hub] 2011-12-05 18:24:11 PST
I have observed this too. The alert for checking whether Firefox is the default or not isn't really spoken out loud.

Taking it.
Comment 6 Hubert Figuiere [:hub] 2012-01-20 15:36:28 PST
With attachment 590095 [details] [diff] [review] it works, but this is not gonna be the patch that land for it associated bug. 

(just for reference)
Comment 7 Hubert Figuiere [:hub] 2012-01-24 11:24:38 PST
Created attachment 591193 [details] [diff] [review]
Alerts are now usable with VoiceOver. r=
Comment 8 Hubert Figuiere [:hub] 2012-01-24 11:34:31 PST
Created attachment 591198 [details] [diff] [review]
Alerts are now usable with VoiceOver. r=
Comment 9 Hubert Figuiere [:hub] 2012-01-24 11:36:21 PST
Comment on attachment 591198 [details] [diff] [review]
Alerts are now usable with VoiceOver. r=

This is extracted from a previous patch as it was irrelevant there, but is relevant to this bug.
Comment 10 Hubert Figuiere [:hub] 2012-01-24 14:02:24 PST
Reviewed over IRC

https://hg.mozilla.org/integration/mozilla-inbound/rev/3e9d7409a091
Comment 11 Hubert Figuiere [:hub] 2012-01-24 18:21:22 PST
*** Bug 499927 has been marked as a duplicate of this bug. ***
Comment 12 Trevor Saunders (:tbsaunde) 2012-01-24 19:11:07 PST
Comment on attachment 591198 [details] [diff] [review]
Alerts are now usable with VoiceOver. r=

just making it r+ by the right person :) sorry I didn't have time to fiddle with bugzilla earlier
Comment 13 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:21:55 PST
https://hg.mozilla.org/mozilla-central/rev/3e9d7409a091
Comment 14 Marco Zehe (:MarcoZ) 2012-01-30 05:50:05 PST
Setting component to what the fix actually is in: Disability Access APIs rather than Cocoa widgets.
Comment 15 Josh Matthews [:jdm] 2012-01-30 09:52:45 PST
>   return [self selectedText] ? : [self text];

Is this actually a legal statement?
Comment 16 Hubert Figuiere [:hub] 2012-01-30 09:58:39 PST
(In reply to Josh Matthews [:jdm] from comment #15)
> >   return [self selectedText] ? : [self text];
> 
> Is this actually a legal statement?

It is 

http://gcc.gnu.org/onlinedocs/gcc-4.2.4/gcc/Conditionals.html#Conditionals

(given the code is Mac specific, gcc and clang support are all that matter)

Note You need to log in before you can comment on or make changes to this bug.