nsPluginsDir should not use nsFileSpec; use nsIFile instead

VERIFIED DUPLICATE of bug 77231

Status

()

Core
Plug-ins
P3
normal
VERIFIED DUPLICATE of bug 77231
19 years ago
17 years ago

People

(Reporter: dougt, Assigned: av (gone))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
nsJVMManager should use nsIFile.  nsFileSpec is unsupported.


nsFileSpec::nsFileSpec() line 828 + 34 bytes
nsPluginsDir::nsPluginsDir(unsigned short 0x0002) line 123 + 29 bytes
nsPluginHostImpl::LoadPlugins(nsPluginHostImpl * const 0x0110d7f4) line 2296
nsPluginHostImpl::GetPluginFactory(nsPluginHostImpl * const 0x0110d7f4, const 
char * 0x01fef690, nsIPlugin * * 0x0012f670) line 2113
nsJVMManager::StartupJVM() line 564 + 32 bytes
nsJVMManager::MaybeStartupLiveConnect() line 700 + 20 bytes
nsJVMManager::StartupLiveConnect(nsJVMManager * const 0x0110b3e8, JSRuntime * 
0x00c3c898, int & 0x00000000) line 128 + 11 bytes
nsJSEnvironment::nsJSEnvironment() line 1101 + 33 bytes

Comment 1

19 years ago
THis is an OJI related bug. Not a Pluglet(java implemented plugins) bug.
Changing category and reassign bug to owner of the OJI component.
Assignee: akhil.arora → drapeau
Component: Java-Implemented Plugins → OJI
QA Contact: geetha.vaidyanaathan → paw

Comment 2

19 years ago
Loki, Ed: can one of you take this on?  Loki, if you can take this on this week 
while Ed is travelling, that would help a lot.  If you can't, just add a comment 
to this bug so Ed and I know.

Comment 3

19 years ago
i'll take a gander indeed.

Comment 4

19 years ago
this bug has _nothing_ to do with OJI (except that the stack trace happens to 
occur while travelling through the plugin load).
a search through all oji code and oji related headers finds no reference to 
nsFileSpec; however, looking at nsPluginsDir, we see that nsPluginsDir indeed 
extends nsFileSpec.

this is not an OJI issue, this is an issue with the mozilla plugins code 
(mozilla/modules/plugins (/nglsrc is the directory containing nsPluginsDir))

andrew volkov(av@netscape.com) should take ownership of this bug (module owner 
for plugins) - but not sure i have the "power" to make that change.. george?

additionally, the summary of this bug should be changed to read "nsPluginsDir 
should not extend nsFileSpec" or something like that (something without the word 
"nsJVMManager" in it...)

Comment 5

19 years ago
Re-assigning to Plug-ins module owner (Andrei: you're it).  Thank you to Loki 
for the analysis that discovered the source of the problem.

Also, changed the summary of the bug to clarify it.
Assignee: drapeau → av
Component: OJI → Plug-ins
Summary: nsJVMManager should use nsIFile → nsPluginsDir should not use nsFileSpec; use nsIFile instead

Comment 6

18 years ago
Removing from CC list.
Not a Netscape 6 RTM blocker. FUTURE. This bug has been marked Future because
the Netscape engineer it is assigned to is overburdened.
Target Milestone: --- → Future

Comment 8

18 years ago
*** Bug 56154 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Updated QA Contact
QA Contact: paw → shrir

Comment 10

17 years ago
Perhaps with the updating of plugin scanning in bug 77231, this can be done as
well. What do you guys think?
Blocks: 102700
Yeah - It's all going to nsIFile in bug 77231. I'd say this is a dup.

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 77231 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.