XML parsing error pages have broken horizontal scrollbars

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: bz)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
wanted-next +
blocking1.9 -
wanted1.9 -
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 254631 [details]
testcase (invalid XML on a long line)

Steps to reproduce:
1. Load the testcase.
2. Try to scroll right to see what tag caused the parse error.

Result: Notice that two-finger scrolling doesn't work, and that the horizontal scrollbar is kinda-present but disabled.

This regressed between 2007-01-29 and 2007-01-31, so I'm guessing it's a regression from bug 18333.
Flags: blocking1.9?
This sounds like a layout bug.
Assignee: xml → nobody
Component: XML → Layout
QA Contact: ashshbhatt → layout
Did bug 380612 fix this symptom?  If so, should there be a bug on the underlying scrollbar layout problem (which seems like a valid bug even if this symptom went away)?

Comment 3

11 years ago
(In reply to comment #2)
With the 2007-05-31-18/OS X Minefield build
* The scrollbar sort of works: there is a scrollbar widget but: click on the thumb and it jumps 1/3 of the screen (left to right). Dragging is not possible. Going back from right to left can only be done by using the arrows.
* Using scrollwheel or trackpad works fine though.
Looks like basically bug 78070.
Depends on: 78070
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]

Updated

11 years ago
OS: Mac OS X → All
Hardware: PC → All

Comment 5

11 years ago
(In reply to comment #3)
At least on current trunk builds /linux there is no way I can get the horizontal scrollbar to move, not even whey selecting all the text of a row using keyboard navigation. 
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
Flags: wanted1.9-
Flags: wanted1.9+
Flags: wanted-next+

Comment 6

9 years ago
I suppose I'll be following this bug.
I decided to start bisecting, and discovered following:

Trunk:
2007-01-27-04 works
2007-02-01-04 broken differently - a scrollbar is presented, but it is full width, as if the content is just slightly larger than the screen (which is not the case).
2007-03-01-04 and up, broken with a scrollbar that is the correct width, but unuseable.

I was using:
http://m8y.org/tmp/invalid.xhtml as a test.

Given the dates, bz's bug reference seems too early, but perhaps it is some ongoing thing.
"My bug reference" is to the bug that causes the problem.  That bug is only an issue if the root element is replaced after frame construction has started.  That never used to happen with XML until incremental XML parsing.  See comment 0.

Various later changes in behavior are probably due to changes in scrollframe, but don't affect the basic problem.
The patch for bug 78070 fixes this bug, but I'm not quite sure how to write a test for this....
Flags: in-testsuite?
And in particular, reftest doesn't do scrollbars on the test, from what I can tell.  And even if it did, I'm not sure how to test for brokenness of them.
Put the XML document with the error inside an iframe?
Hmm...  That does show them (including in current builds), but still not sure how to test that they work.  I'll poke at it.
OK, I've finally managed to write a mochitest for this.  I'll include it in the patch for bug 78070.
Fixed by checkin for bug 78070.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
Assignee: nobody → bzbarsky

Updated

9 years ago
Depends on: 492575
That random failure is filed as bug 492575.
Duplicate of this bug: 510484
You need to log in before you can comment on or make changes to this bug.