subscribe to IMAP folders window doesnt allow subscribing to folders below 2nd level

RESOLVED DUPLICATE of bug 592633

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 592633
11 years ago
8 years ago

People

(Reporter: u271506, Assigned: Dale Wiggins)

Tracking

unspecified
Thunderbird 3.0b3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 3 alpha 1 (20070209)

If more than 2 levels of folders exist on the IMAP server (as is the case with my exchange 2003 server account), the 2nd level folder doens't display a + icon to expand down to the next level of folders, and there is no other way to expand the node (no right click or double click), hence folders below the 2nd level can't be subscribed to.

Reproducible: Always

Steps to Reproduce:
1. Setup IMAP account to exchange server with more than 2 levels of folders
2. Open subscribe window
3. Drill down into a folder that has more than two levels on the IMAP server. only the first two levels will show.
Actual Results:  
Only the first two levels of folders are shown.

Expected Results:  
Subsequent levels of folders should be displayed and be subscribeable

Comment 1

10 years ago
its dupe for ms exchange
Whiteboard: dupeme

Updated

10 years ago
Assignee: mscott → nobody
(Assignee)

Updated

9 years ago
Assignee: nobody → dwiggins
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

9 years ago
Created attachment 353262 [details] [diff] [review]
Attempted fix for subscribe issue

It seems Exchange doesn't like LIST commands that don't end in "%", at least in this case. This should take care of that.
Attachment #353262 - Flags: superreview?(bienvenu)
Attachment #353262 - Flags: review?(mnyromyr)

Comment 3

9 years ago
Re comment #0:
The only IMAP server available to me which supports subfolders is Google, so I created a hierarchy:

- sub0
  - sub1
    - sub2
      - sub3
        - sub4
            sub5

and indeed our subscribe dialog doesn't show twisties _on_first_try_:

  INBOX
+ [Gmail]
+ sub0

Clicking the + before sub0 will change it to:

- sub0
    sub1

Closing and reopening sub0 results in:

- sub0
  + sub1

with sub1 expanding to:

- sub0
  - sub1
      sub2

etc. pp.


Re comment #2:
... but this patch doesn't fix that at all, because OnListFolder isn't called in this context?!

And I'm not sure that adding a random % to all LIST commands is a good idea, generally.

Comment 4

9 years ago
(In reply to comment #3)
> and indeed our subscribe dialog doesn't show twisties _on_first_try_:

I can confirm your description.
To provide a server log, I created the same structure on my local server (Hamster).

'INBOX' & 'Trash' are selected and 'sub0' and below folders are not selected.
I opened the "Subscribe"-dialog and got:

| > 3 lsub "" "*"
| < * LSUB () "/" "INBOX"
| < * LSUB () "/" "Trash"
| > 4 list "" "%"
| < * LIST () "/" "INBOX"
| < * LIST () "/" "sub0"
| < * LIST () "/" "Trash"
| > 5 list "" "%/%"
| < * LIST () "/" "sub0/sub1"
| > 6 lsub "" "*"
| < * LSUB () "/" "INBOX"
| < * LSUB () "/" "Trash"
| > 7 list "" "%"
| < * LIST () "/" "INBOX"
| < * LIST () "/" "sub0"
| < * LIST () "/" "Trash"
| > 8 list "" "%/%"
| < * LIST () "/" "sub0/sub1"

{Why asks TB that sequence twice? – That is probably a different story.}
The Dialog now shows:

  INBOX
+ sub0
  Trash

> Clicking the + before sub0 will change it to:
> - sub0
>     sub1

Confirmed. And the log says:

| > 9 list "" "sub0/%"
| < * LIST () "/" "sub0/sub1"
| > 10 list "" "sub0/%/%"
| < * LIST () "/" "sub0/sub1/sub2"

TB should have recognized that sub1 has a subfolder.

> Closing and reopening sub0 results in:
> - sub0
>   + sub1

Also confirmed. And the log says:

| > 11 list "" "sub0/%"
| < * LIST () "/" "sub0/sub1"
| > 12 list "" "sub0/%/%"
| < * LIST () "/" "sub0/sub1/sub2"

Again this is the same sequence as above.
Is it possible, that TB has missed to add the twisty or just has missed to redraw the view at the first time?

HTH

Comment 5

9 years ago
WFIW, the patch still applies. (xref bug 472129?)
Component: Account Manager → Networking: IMAP
OS: Windows XP → All
Product: Thunderbird → MailNews Core
QA Contact: account-manager → networking.imap
Hardware: x86 → All
Whiteboard: dupeme
Target Milestone: --- → Thunderbird 3.0b3

Comment 6

9 years ago
Created attachment 365462 [details] [diff] [review]
Fix by fetching three levels of subfolders

Because attachment (id=353262) didn't change anything for me, I created an alternative Patch.
This is a little ugly workaround, but it works (for me). It asks the server for 3 levels of subfolders instead of only 2.
As written in comment #4, problem is "no expand button is added to sub1" even after Tb knows about children of sub0/sub1/sub2 by list sub0/%/%. Cause is not "two level only of LIST", although it's relevant to problem.
Problem is being processed by Bug 592633 and patch has been proposed to that bug. No need to keep separate bug. Closing as DUP. Re-open bug if not same problem, please.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592633
Comment on attachment 353262 [details] [diff] [review]
Attempted fix for subscribe issue

Based on previous comments, this is a duplicate of bug 592633 and appears to be being resolved in a different manner. Therefore cancelling what appear to be obsolete reviews.

If the patch is still required after bug 592633 is fixed, please make sure it gets attached to a relevant open bug where we can handle it better. Thanks.
Attachment #353262 - Flags: superreview?(bienvenu)
Attachment #353262 - Flags: review?(mnyromyr)
You need to log in before you can comment on or make changes to this bug.