Last Comment Bug 370108 - Enabling FKA while a prefPane is open does not focus any controls
: Enabling FKA while a prefPane is open does not focus any controls
Status: RESOLVED FIXED
: access, fixed1.8.1.12, regression
Product: Camino Graveyard
Classification: Graveyard
Component: Preferences (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: Camino1.6
Assigned To: Mark Mentovai
:
:
Mentors:
Depends on: 371484
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-11 17:14 PST by Smokey Ardisson (offline for a while; not following bugs - do not email)
Modified: 2008-01-03 11:43 PST (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-02-11 17:14:10 PST
In all of our prefPanes without text fields, enabling FKA while the pane is open does not focus the first control; you have to switch to another prefPane to get a focused control (or click on a control with the mouse).

Compare with Safari, which focuses the first control in a prefPane when you enable FKA while the prefPane is open.
Comment 1 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-02-15 20:44:55 PST
This is technically a regression, probably from bug 327203.
Comment 2 Mark Mentovai 2007-12-31 15:55:03 PST
Safari does what, now?  I don't see it focusing the first control automatically when FKA is turned on, you still need to press tab to get the first control focused.  STR:

FKA off
Safari:Preferences…:Tabs
Observe: in Safari's Preferences window, there's properly no focus ring.
FKA on
Observe: No focus ring.  Press tab and a focus ring appears around the first
         checkbox.
Switch to the Security pane (FKA still on)
Observe: the first checkbox correctly has a focus ring.
FKA off
Observe: the first checkbox still has a focus ring and will respond to the
         space bar.  There's no way to make it relinquish focus.  Tab does
         nothing.
FKA on
Switch to the General pane
Observe: "Home page" field has focus
Tab to something that's not a checkbox, such as the Set to Current Page button
FKA off
Observe: the Current Page button still has a focus ring and will respond to the
         space bar.  When tab is pressed, focus moves to the Home Page field,
         the only text field in the pane.  Subsequent tab presses leave focus
         in this field.

Safari 3.0.4 (5523.10.6) on 10.5.1 (9B18).

I can make our preferences window match all of these behaviors in bug 371484.  My current v1 patch there doesn't do this, but my upcoming v2 patch will.

Comment 0 seems to suggest that you'd like a focus ring to automatically spring into existence when FKA is turned on, but I don't see Safari doing that.  You don't mention anything about what happens when FKA is turned off, and that seems like the more serious problem to me, but again, Safari leaves an unfocusable control focused in this case, and I know how to make us do that in bug 371484, too.

It looks like we can pick up a KeyboardUIModeDidChangeNotification to fix focus when FKA is turned on or off.  This would probably be pretty easy.  As far as I can see, this is an AppKit behavior shared by Safari's Preferences window and all other Cocoa key view loops including our toolbar, dialogs, and you-name-it.  As such, I don't know if it's worth fixing in Camino.  (It would be great if AppKit fixed it, though.)
Comment 3 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-12-31 17:16:45 PST
Wow, we have three completely different Safaris, or two horked OSes, or something.

As you might expect, comment 0 was written against 10.3.9/Safari 1.3.x, but I continue to get the same behavior in 10.5.1 (Intel; 9B18)/Safari 3.0.4 (5523.10.6).

(In reply to comment #2)
 
> FKA off
> Safari:Preferences…:Tabs
> Observe: in Safari's Preferences window, there's properly no focus ring.
> FKA on
> Observe: No focus ring.  Press tab and a focus ring appears around the first
>          checkbox.

Observe: "⌘-click opens a link in a new tab" gets a focus ring immediately after enabling FKA.

> Switch to the Security pane (FKA still on)
> Observe: the first checkbox correctly has a focus ring.
> FKA off
> Observe: the first checkbox still has a focus ring and will respond to the
>          space bar.  There's no way to make it relinquish focus.  Tab does
>          nothing.

Observe: Focus ring vanishes from "Enable plug-ins"

> FKA on
> Switch to the General pane
> Observe: "Home page" field has focus
> Tab to something that's not a checkbox, such as the Set to Current Page button
> FKA off
> Observe: the Current Page button still has a focus ring and will respond to the
>          space bar.  When tab is pressed, focus moves to the Home Page field,
>          the only text field in the pane.  Subsequent tab presses leave focus
>          in this field.

Observe: "Set to Current Page" loses focus and the focus ring; focus and the focus ring return to the Home Page field.

What's the difference here?  Both my Safaris do this.

Oh, how are you enabling FKA?  I'm always using Fn-Ctrl-F7 (on both 10.3.9/10.5.1).
Comment 4 Mark Mentovai 2007-12-31 17:46:36 PST
I was turning FKA on and off in System Preferences.  When I use Fn-Ctrl-F7 in Safari, the cases above behave as you say.  In conjunction with the v2 patch in bug 371484, Fn-Ctrl-F7 results in Camino behaving this way ("properly"), too.
Comment 5 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-12-31 18:41:00 PST
--> mento, too
Comment 6 Mark Mentovai 2008-01-03 11:43:54 PST
The fix for this was checked in along with bug 371484 on the trunk and MOZILLA_1_8_BRANCH for 1.6b1.

Note You need to log in before you can comment on or make changes to this bug.